Enable chunking v2 for Object Storage S3

Nextcloud version (eg, 20.0.5): 28.0.3
Operating system and version (eg, Ubuntu 20.04): Ubuntu server 22.0.4
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.52
PHP version (eg, 7.4): 8.1

The issue you are facing:

Hello everyone,

I’m still a neophyte on Nextcloud, so excuse me if I say aberrations or mistakes.

I have a next cloud with Primary stroage: Object storage S3.

For storage that can be expanded as required.

When I upload large files (>20 GB) I get the message “unknow error”.

I’ve noticed that my local system storage (which is 20 GB max) is 100% full when uploading, and that the message appears at this point.

From the research I’ve been able to do, I’ve deduced that this is one of the problems with chunking, which assembles the file locally into a temporary file before sending it to the S3 object storage.

My question is whether my resonance is good? And if so, is there any way of solving this problem without having to increase my server’s local storage (for me, this solution is not scalable)?

I’ve seen that version 2 of chunking on nextcloud allows this without having to first assemble the file on the local server. With the “MultipartUpload for uploading chunks to s3” feature.


Could this solve my problem and if so how do I activate it?

Thank you very much for your feedback

What are your memcache.* settings? v2 chunking depends on memcache.distributed being configured and being either Redis or Memcached. Without it, the fallback is v1[1].

EDIT: I should also mention that how you’re uploading matters to. I responded assuming you’re using either the Web UI (web Files client) or one of the official mobile/desktop Files clients.

[1] fix: Validate that we have a proper distributed cache configured by juliushaertl · Pull Request #41354 · nextcloud/server · GitHub


Thank you for your prompt reply.
(Yes sorry for the upload I use the the Web UI)

I don’t have a memory caching system on my server because I didn’t see the point and it was optional.

If I activate it, it will activate version 2 of chunking and solve my problem?

Thank you in advance and have a nice day!

Yes, it should.

Also your situation reminded me there is still probably a gap in the docs for v2 chunking (which is fairly new) on the Admin side… I’ll see what I can do about that.


I’ve just implemented memcache on my server with APCU at REDIS.
So chuncking v2 is automatically activated?

It seems to work when I use an account on the web page, the assembly no longer seems to be done on the server locally. So that’s good, but it still doesn’t work on the “File drop” share page.
I’ve just noticed this point in the documentation, so that might explain it.

Previously I had only tested uploading with “file drop”, I wonder if uploading would have worked from the user page. I think not, since chuncking v2 wasn’t enabled, but it’s an interesting point.

Do you think this feature could be added to the “File Drop” web page in the future?


Chunking for File drop (public/anonymous uploads) is planned, but not yet implemented. Give it an upvote if so inclined: Allow chunked public upload · Issue #4109 · nextcloud/server · GitHub


Thanks for the information. Great I will do it !
Thanks again for your help !

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.