eMail Server Einstellungen

Hallo,

ich wollte gerade den email Server in den Einstellungen von der Nextcloud setzen, aber beim testen wird mir immer ein Fehler ausgegeben, obwohl alle Zugangsdaten aber zu 100% richtig sind :

Beim Senden der E-Mail ist ein Problem aufgetreten. Bitte ĂŒberprĂŒfen Sie Ihre Einstellungen. (Fehler: Connection to tcp://mail.Meine-Domain.nrw:465 Timed Out)

Mache ich hier etwas falsch ? Ich weiss nicht mehr woran es liegen könnte.

Hast du einen E-Mail-Server unter der Adresse laufen?
Ist der fehlerfrei konfiguriert?
Kannst du mit anderen Email-Clients mit diesen Einstellungen Emails abrufen?

Bitte poste deine config.php ( und achte & entferne sensitive Informationen)

Hallo,

ja unter der Adresse habe ich einen eMail Server laufen (eigener Server) und der funktioniert auch einwandfrei. Z.b. mit Thunderbird kann ich mit dieser eMail Adresse ohne Probleme eMails abrufen und auch empfangen.

Wenn ich die Config.php runter laden möchte, bekomme ich folgende Meldung :
Received error message from remote side: ‘scp: config.php: Permission denied’

wo und wie hast du deine Instanz gehostet?

Zur Not mach eine Bildschirmkopie von der Email.Server-Seite innerhalb von NC. das ist schon mal ein 1. Schritt.
Oder Du lĂ€sst dir einen Support-Bericht anfertigen von deiner Instanz
 Unter https://deine.cloud.TLD/settings/admin/support und da dann “Supportbericht erstellen” - da sind dann i.d.R. alle sensiblen Inhalte unkenntlich gemacht.

Interessant wÀren auch:

  • Logdatei-EintrĂ€ge des Mailservers, sofern zugĂ€nglich
  • Verbindungstest vom Nextcloud-Server zum Mailserver mit “ping”-Befehl und gem. dieser Anleitung, wenn Du auf dem Nextcloud-Server Zugriff auf die Konsole (z.B. mit ssh) hast:
    ITWelt.org - Postfix: TLS testen mit dem OpenSSL s_client

OK, soll ich den Inhalt der Datei hier Posten ? Weil die Datei hier hochladen geht nicht.

Hallo,

puuuu, da weiss ich leider nicht was ich da machen soll wegen dem Verbindungstest. Es war ja alles mal eingestellt und funktionierte auch mit den Mails. Nun gehts nicht mehr.

ja bitte, den Inhalt hier posten
 ggf in mehreren Postings

Server configuration detail

Operating system: Linux 5.4.0-131-generic #147-Ubuntu SMP Fri Oct 14 17:07:22 UTC 2022 x86_64

Webserver: Apache/2.4.41 (Ubuntu) (apache2handler)

Database: mysql 10.5.15

PHP version: 7.4.3

Modules loaded: Core, date, libxml, openssl, pcre, zlib, filter, hash, Reflection, SPL, session, standard, sodium, apache2handler, mysqlnd, PDO, xml, apcu, bcmath, calendar, ctype, curl, dom, mbstring, FFI, fileinfo, ftp, gd, gettext, gmp, iconv, igbinary, imagick, intl, json, exif, mysqli, pdo_mysql, apc, posix, readline, redis, shmop, SimpleXML, sockets, sysvmsg, sysvsem, sysvshm, tokenizer, xmlreader, xmlrpc, xmlwriter, xsl, zip, Phar, Zend OPcache

Nextcloud version: 24.0.6 - 24.0.6.1

Updated from an older Nextcloud/ownCloud or fresh install:

Where did you install Nextcloud from: unknown

Signing status

Array ( )

List of activated apps
Enabled:
 - accessibility: 1.10.0
 - activity: 2.16.0
 - bruteforcesettings: 2.4.0
 - calendar: 3.5.0
 - circles: 24.0.1
 - cloud_federation_api: 1.7.0
 - comments: 1.14.0
 - contacts: 4.2.2
 - contactsinteraction: 1.5.0
 - dashboard: 7.4.0
 - dav: 1.22.0
 - federatedfilesharing: 1.14.0
 - federation: 1.14.0
 - files: 1.19.0
 - files_pdfviewer: 2.5.0
 - files_rightclick: 1.3.0
 - files_sharing: 1.16.2
 - files_trashbin: 1.14.0
 - files_versions: 1.17.0
 - files_videoplayer: 1.13.0
 - firstrunwizard: 2.13.0
 - logreader: 2.9.0
 - lookup_server_connector: 1.12.0
 - mail: 1.13.8
 - nextcloud_announcements: 1.13.0
 - notifications: 2.12.1
 - oauth2: 1.12.0
 - password_policy: 1.14.0
 - photos: 1.6.0
 - privacy: 1.8.0
 - provisioning_api: 1.14.0
 - recommendations: 1.3.0
 - richdocuments: 6.2.0
 - richdocumentscode: 22.5.502
 - serverinfo: 1.14.0
 - settings: 1.6.0
 - sharebymail: 1.14.0
 - spreed: 14.0.5
 - support: 1.7.0
 - survey_client: 1.12.0
 - systemtags: 1.14.0
 - text: 3.5.1
 - theming: 1.15.0
 - twofactor_backupcodes: 1.13.0
 - updatenotification: 1.14.0
 - user_status: 1.4.0
 - viewer: 1.8.0
 - weather_status: 1.4.0
 - workflowengine: 2.6.0
Disabled:
 - admin_audit
 - encryption
 - files_external: 1.15.0
 - user_ldap

Configuration (config/config.php)
{
    "instanceid": "***REMOVED SENSITIVE VALUE***",
    "passwordsalt": "***REMOVED SENSITIVE VALUE***",
    "secret": "***REMOVED SENSITIVE VALUE***",
    "trusted_domains": [
        "markpeter.ddnss.de"
    ],
    "datadirectory": "***REMOVED SENSITIVE VALUE***",
    "dbtype": "mysql",
    "version": "24.0.6.1",
    "overwrite.cli.url": "http:\/\/markpeter.ddnss.de",
    "dbname": "***REMOVED SENSITIVE VALUE***",
    "dbhost": "***REMOVED SENSITIVE VALUE***",
    "dbport": "",
    "dbtableprefix": "oc_",
    "mysql.utf8mb4": true,
    "dbuser": "***REMOVED SENSITIVE VALUE***",
    "dbpassword": "***REMOVED SENSITIVE VALUE***",
    "installed": true,
    "app_install_overwrite": [
        "files_external_gdrive"
    ],
    "default_phone_region": "DE",
    "memcache.local": "\\OC\\Memcache\\Redis",
    "memcache.locking": "\\OC\\Memcache\\Redis",
    "filelocking.enabled": "true",
    "redis": {
        "host": "***REMOVED SENSITIVE VALUE***",
        "port": 0,
        "timeout": 0
    },
    "mail_smtpmode": "smtp",
    "mail_sendmailmode": "smtp",
    "mail_smtphost": "***REMOVED SENSITIVE VALUE***",
    "mail_smtpport": "465",
    "maintenance": false,
    "updater.release.channel": "stable",
    "theme": "",
    "loglevel": 2,
    "mail_smtpsecure": "tls",
    "mail_smtpauth": 1,
    "mail_smtpauthtype": "LOGIN",
    "mail_from_address": "***REMOVED SENSITIVE VALUE***",
    "mail_smtpname": "***REMOVED SENSITIVE VALUE***",
    "mail_smtppassword": "***REMOVED SENSITIVE VALUE***",
    "mail_domain": "***REMOVED SENSITIVE VALUE***"
}

Cron Configuration: Array ( [backgroundjobs_mode] => cron [lastcron] => 1667160026 )

External storages: files_external is disabled

Encryption: no

User-backends:

  • OC\User\Database

Talk configuration:

STUN servers

  • no custom server configured

TURN servers

  • no custom server configured

Signaling servers (mode: default):

Hallo @MarkPeter

Du hast ziemlich sicher, den falschen Port oder die falsche VerschlĂŒsselungsart angeben. STARTTLS lĂ€uft normalerweise ĂŒber Port 587, wĂ€hrend Port 465 bei den meisten Anbietern fĂŒr implizites SSL/TLS verwendet wird. Welche VerschlĂŒsselungsart auf welchem Port dein Anbieter nutzt, sollte auf der Webseite des Anbieters zu finden sein


Also nachdem ich ein bisschen rumgeschaut habe, fÀllt mir einiges auf, was aber nicht dein Problem löst.

  • du hast deinen Host als http aufgesetzt, also ohne Zertifikate?
  • dein Host ist von außen nicht erreichbar
  • dein mailhost hat eine ganz andere Adresse
  • dein mailhost wird durch “tcp://xyz” angesprochen
 Das sieht merkwĂŒrdig aus, ist aber vielleicht richtig (ich bin nicht so sehr in der Materie drin)
  • wie @bb77 schon sagte: der Port stimmt nicht mit den Standards ĂŒberein, was nicht falsch sein muss in deinem Fall, da du dein eMailserver ja selbst konfiguriert haben willst (was IMMER ein potenzielles Problem sein kann)

Als Fragen tauchen auf:

  • Welche TLS-Version fĂ€hrst du auf deinem Host? - Da kannst du in der Config.php drauf eingehen und diese Version explizit erlauben
  • Du fĂ€hrst offenbar unter Plesk. Vielleicht gibt es dort im Forum hilfreiche Lösungen zu deinem Problem
  • Mögliche Lösungen mag es auch hier geben, wenn du die SuFu bemĂŒhst.

Ich kann dir leider nur nicht sehr hilfreich sagen: das Problem liegt mit ĂŒber 90%er Wahrscheinlichkeit an deinen Einstellungen. Möglicherweise am Mailserver.

Ich kann hier nicht weiter helfen, tut mir Leid.

Vielleicht findet jemand anderes die Lösung. Oder du selbst durch suchen!
Bitte lass uns, falls du das selbst lösen kannst, doch die hilfreiche Lösung als Antwort hier drunter da


Viel Erfolg

Nein, mein Host ist natĂŒrlich gesichert
Von außen erreichbar ist er
Der Mailhost hat keine andere Adresse als meine eigene Domain
Das der Port nicht stimmt, ist falsch, es ist Port 465 und nicht 587

Problem wurde aber durch die falsche VerschlĂŒsselung gelöst, ich muste nicht
STARTTLS auswÀhlen, sondern SSL/TLS, dann gespeichert und schwupps ging
die Test eMail auch raus und kam bei mir an. Bilder als Anhang.

Mark-Peter