Editing Pico CMS Pages Directly in Nextcloud

Hello, how to edit Pico pages directly in Nextcloud?

The “Markdown Editor” plugin depends on the old “Plain Text Editor”, which doesn’t work on Nextcloud 19.0.3 anymore.

What is the way now to edit Pico pages if the recommended method doesn’t work?

If you have any issues with Markdown Editor and/or Plain Text Editor, please report this to the respective developers, so they can fix the issues. Please add a link to the GitHub issues here for reference. Unfortunately we can’t do anything about issues in other apps. In the meantime you can edit your files locally.

See this [SOLVED] Does Markdown Editor no longer work?

You can install and activate Plain text Editor and after that you clique on the three dots and choose Plain text editor. Works in 19.03.

Thank for the tips, but even though I installed “Plain Text Editor” (I did so using the occ command as right now, nobody can download it through Apps because of a certificate error), I don’t see the “Edit with Plain Text” or something under the 3-dots menu, I tried everything (such as disabling the new Text app).

I have Plain Text editor, Markdown Editor and Text installed. I can see them all as activated in the Apps view. When I rightclique on the three dots for a md-file I have the alternative to edit with Plain text editor.
My server is Ubuntu 18.0.4 with Collabora and OnlyOffice in Docker behond Nginx. I use Windows 10.

An alternative is to use the client and then edit the local copies of the .md-files

maybe you can try to disable and reenable Plain text and Markdown editor?

I tried all combinations of enable/disable in every order possible. All 3 apps are activated, but I cannot see the alternative editor in the 3-dots for md files. Which version of Nextcloud do you have, the latest 19.0.3?

I installed Plain Text Editor using the OCC command, as there is an issue currently if we go through the app store: https://github.com/nextcloud/files_texteditor/issues/271

I downloaded it with git, and moved the folder under “/var/www/html/nextcloud/apps/files_texteditor/” and changed the ownerships recursively to “apache:apache”.

I tried restarting the server, rebooting, etc. I cannot see the alternative editor beside the 3-dots:

Same problem here…

But I tried to install this fork of plain text editor in my nc19:

And that one is working and can be used together with the Markdown Editor.


I have Plain Text Editor 2.11.0 and NC 19.0.3 I isntalled it maybe 6 months ago or more. I works with no problem also after updating from 19.0.2 to 19.0.3


and I can find it in the app-store

Yeah but when trying to install it, there is the “Certificate “4356” has been revoked” bug that is now affecting multiple people: https://github.com/nextcloud/files_texteditor/issues/271

I will try a fork and see how it goes, hopefully they fix that app soon though. Thanks for the help btw!