E2E encryption not working 15.0


I am using nextcloud 15.0 and downloaded and enabled the E2E app. When I connect from a Windows 10 client, the ap gives me a 12 dictionary word password and I chose to sync couple folders. After that when I right click on a synced folder (it has only one file test.txt), and select encrypt, I am getting a pop up error message “Please wait for the folder to sync before trying to encrypt it”.

Searching google, it seems some folks got it working by deleting the app, deleting the table and then reinstalling the app. I have tried that as well couple times, but doesn’t seem to work.

Thanks for help.

PS: tried on mac as well running latest Mojave with the latest nextcloud client, getting the same error there as well.

2nd Update: In the case above I was actually doing partial sync (only 2 folders) and rest of the folders were not being synced. I decided to create a new account and set it up with the desktop client to sync everything. Now when I select Encrypt, if there is any file in the folder, it notifies me that only empty folders can be set to encrypt. When I emty the folder and select it to encrypt, it works and a green padlock appears next to the folder. However when I create a new subfolder, the green padlock next to the main folder goes away or if I create a file when the green lock is there, I don’t see it encrypted on server side? What am I doing wrong?

Same effect here with Mojave and Nextcloud client 2.5.1final (build 20181204), Nextcloud 15.0.2 with Nginx as webserver used. Creating a new account and syncing this first doesn’t change anything.

Accrording to some repots in the bugtracker it seemss that the desktop client has some problems with syncinc subfolders and encrypting them recursivley… perhaps you can check if they fit to your problem. You find some of them here: