-e SKIP_DOMAIN_VALIDATION=true on AIO Virtualbox appliance?

I setup the standard docker AIO MULTIPLE TIMES on a fresh Ubuntu 20.04 server / Linux Mint and there is no way to get past the 443 not open error no matter what you do since the 1.7 update (i was able to setup 1.6 on the first try with no issues on a linux mint box.)

With the -e SKIP_DOMAIN_VALIDATION=true switch i was able to finish the setup, but the instance is unusable performance wise, and it does not even work if i am inside the same network where the server resides.

I have moved the server to a different location, with a completely different network/IP/router to no avail.

I am giving the AIO Virtualbox a chance now, and it has the same 443 port not open issue.
Is there anyway to skip the domain validation on the virtualbox appliance?

Related to my issue… i am testing with the VM because i believe the DNS problem could be the way the subdomain i am using is being handled by the registrants.

The problematic domain is in godaddy, and i created the subdomain pointing to the IP address from the godaddy DNS options.

The 1.6 instance i mentioned above was setup differently with a different domain in namecheap > cPanel taking care of the redirection.

So now i am using a different test domain with the same Namecheap>cPanel redirection to troubleshoot but i continue getting the 443 not open error.

The router i am using is Mikrotik in 3 different locations. and i have opened the needed ports the same way everywhere. Portchecker.co shows ports 80,443,8443 are open.

Thank you