Dumb Question re hostname/port

I appear to have successfully installed Nextcloud on a Centos7 VPS. As a novice I’m pleased with myself.

I have it serving the initial setup page in a browser window, and everything makes sense until I get to the last field: host name.

This is prefilled with ‘localhost’, but I want to enter the (fixed) IP address of my VPS (I think…). Fine.

Then I read a note underneath which says; ‘Please specify the port number along with the hostname (eg localhost:5432)’ - and now I’m stumped.

I follow the documentation link below that, but there is nothing that I can find about this issue.

Is there a default port number?
If not, how do I discover / set a port number?
Or should I be leaving it as localhost??

Nowhere in these setup instructions did I see anything about a port number.

Thanks for reading!

Can you make a screenshot of that page and either attach it here or send us a link, where we can find it? Not sure what step you are referring to with the host/port thing

If the following image shows that step, leave host as localhost and if asked for a port just use either the default one or change it to 3306

Thanks for this. Yep, that’s the screen I’m seeing.
It’s the last white box, and indeed it is defaulted to localhost.

So I went ahead, and got this message:

Hmmm, I thought. Maybe nothing happened .

So I tried again to connect with /localhost, and got this:

Now I’m really stuck…

On most systems, if you use MariaDB as MySQL database you should enter refers to the same localhost, but interpretation is different.
The default port that is used is 3306 for standard (older) MySQL databases. In that case you should enter

But I get also errors with a new installation. Also the 1045 error. Try to have a look at the config.php that is created in the config folder. Are the databasename and databaseuser and port settings as you have entered?

Have you actually installed a database engine?

Yup, I very definitely followed the steps in the instructions to install mariadb and secure the mysql.

Thanks for these. I think I’m going to do a clean install and use these settings you suggest, see what happens.

The instructions I used have a whole section on selinux, which I tried to implement with no success - eventually finding something which suggested that it isn’t part of the VPS install that I’m working off - so maybe I glitched something there…

Try first to connect to MariaDB with Mysqladmin and see if the user exists and if you have a database that is fully accessible by the user you made.