Downloading folders broken in nc 28?

I recently updated to nextcloud hub 7 (NC28) but I am experiencing issues with downloading folders or multiple files in the webgui. Instead of generating and downloading a zip file, the download location prompt is for a download.htm file now, which also fails due to a “site not available” error.

looking in the nginx logs I got the following entry

"OC_Util" not found in /config/www/nextcloud/apps/files/ajax/download.php:31

I thought this was a bug at first, but there have been 3 updates since that hasn’t fixed it for me, making me think the issue is with my configuration?

Anyone has the same trouble?

Nextcloud version : 28.0.0.11 (docker container)
Operating system and version : Unraid 6.12.6
nginx version: 1.24.0
PHP version: 8.2.13
Instance running behind nginx reverse proxy

I can confirm. On my test servers with NC28, I get a “download.php” instead of a zip file.

No docker, vanilla server on virtual machine.

Much luck,
ernolf

ah thx for the confirmation. So I guess it’s waiting for a patch on this

I did not find any Issue about this yet. Maybe someone else?
If not, you could file one here:

Much luck,
ernolf

For me it is working fine on a test server with 28.0.1 (manual installation).

Try upgrading to 28.0.1. If the error persists, it might be an issue with your reverse proxy configuration or with the docker image.

Yeah, I posted the issue on the nextcloud repo (https://github.com/nextcloud/server/issues/42470), but they claim the issue is likely related to the image I use.

Given that ernolf also experienced it on another deployment method, it’s indeed likely its a config issue with the reverse proxy or something.

Posted the issue on the linuxserver.io forums to make sure it’s not the image, as that is the docker image I use.

For me it is solved, it was the (not yet supported) App “Configurable Share Links - cfg_share_links” that was causing this behaviour. Disabling that app did solve it and I get a normal zipfile.
Good: Now I know that cfg_share_links does not work and I filed the bug there

So sorry for my noise!

Much luck,
ernolf

yeah checked all the non official apps too, but the issue persist even if I disable them all.

See update here: [Bug]: Downloading multiple files or folder from webgui does not work · Issue #42617 · nextcloud/server · GitHub

It arises from having an outdated web server configuration, that lacks the rewrite handling for ajax (and other) urls. Or at least that was the only way I was able to reproduce this behavior.

Maybe there are other ways of triggering it, given @ernolf got the behavior using the cfg_share_links app (which I’m not familiar with the internals of).

My testing was limited to stock/shipped NC Server apps. If a third-party app can also trigger this behavior that’ll have to be addressed by that app generally.