Download size limit

Hi there

I have trouble downloading files > 512 MB.
Uploading big files works fine, but downloading stops right at 512 MB (512’000 KB = 500 MB to be precise).

My server:

Nextcloud says:

  • Memory limit: 15.6 GB (set to 16'000 MB in .user.ini)
  • Max execution time: 3600 (server only allows 300 s, but that is not an issue with good internet speed)
  • Upload max size: 15.6 GB

The .user.ini file has the following content:

mbstring.func_overload = 0
always_populate_raw_post_data = -1
default_charset = 'UTF-8'
output_buffering = 0
upload_max_filesize = 16000M // server is set to 256M from 500M allowed
post_max_size = 16000M
memory_limit = 16000M
max_execution_time = 3600

I also tried to change settings using .htaccess files, but until now without success.

Does anybody have an idea, where the download limit might origin from?

Thanks for any advice.


Do you store files on the same server where NC or on smb share?

Thanks, Alex, for your help.

The files are stored on the same server without using SMB.

we use just the same settings:

Did you check that all of them are used by system? Do memory_limit is possible to set for more them 512M ?

I indeed can set the memory_limit to higher values than 512M, what I already did. But even with a memory_limit of 1024 M or – the other way – 128M (in both the system settings and .htaccess files at the same time) the download stopped at 512M.

I’m not sure how to check if all of those settings are used by the system.
In the server management itself I can set values for

* max_execution_time
* upload_max_filesize
* post_max_size
* memory_limit

None of these seem to have an influence on the discussed issue.

It must be a nextcloud related issue, because downloading from other sources on the server does work.
Even fresh Nextcloud installations with both MySQL and SQlite as database have this issue on my server.

to check settings, you may use command
sudo -u “your_web_user” php -i | grep memory_l

It seems that I can’t use sudo on my managed server, but with standard user I get the default values of the mentioned settings. This information probably does not help, but at least none of those settings have a value of 500 or 512 MB.