Download fails: Looks like timeout issue

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version ( 15.0.5):
Operating system and version (eg, Ubuntu 18.04):
Webhost: Caddy
PHP version ( 7.2):

The issue you are facing:
Download of bigger files fail. Also speed doesn’t seem to be right. The server is connected with 400 Mbit/s and I am with 200 Mbit/s wich I usually get. I see download speeds as high as 68 Mbit/s. At some point the connection breaks and I don’t know why.

Is this the first time you’ve seen this error? (Y/N):N

Steps to replicate it:

  1. Setup Nextcloud with Caddy as Server

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /etc/php/7.2/fpm/php.ini (make sure you remove any identifiable information!):

; File Uploads ;

; Whether to allow HTTP file uploads.
file_uploads = On

; Temporary directory for HTTP uploaded files (will use system default if not
; specified).
upload_tmp_dir = /mnt/data/nextcloud

; Maximum allowed size for uploaded files.
upload_max_filesize = 16G

; Maximum number of files that can be uploaded via a single request
max_file_uploads = 50

php_value upload_max_filesize 16G
php_value post_max_size 16G
php_value max_input_time 3600
php_value max_execution_time 3600


The output of yourCaddy log:

None, no errors.

Caddy config: {
root /var/www/nextcloud

fastcgi / /run/php/php7.2-fpm.sock php {

fastcgi / php {
        env PATH /bin

rewrite {
    r ^/index.php/.*$
    to /index.php?{query}

# client support (e.g. os x calendar / contacts)
redir /.well-known/carddav /remote.php/carddav 301
redir /.well-known/caldav /remote.php/caldav 301

# remove trailing / as it causes errors with php-fpm
rewrite {
    r ^/remote.php/(webdav|caldav|carddav)(\/?)$
    to /remote.php/{1}

rewrite {
    r ^/remote.php/(webdav|caldav|carddav)/(.+)(\/?)$
    to /remote.php/{1}/{2}

 .htacces / data / config / ... shouldn't be accessible from outside
rewrite {
    r  ^/(?:\.htaccess|data|config|db_structure\.xml|README)
    status 403

header / {
Strict-Transport-Security “max-age=31536000; includeSubdomains; preload;”
# Enable cross-site filter (XSS) and tell browser to block detected attacks
X-XSS-Protection “1; mode=block”
# Prevent some browsers from MIME-sniffing a response away from the declared Content-Type
X-Content-Type-Options “nosniff”
# Disallow the site to be rendered within a frame (clickjacking protection)
X-Frame-Options “DENY”
Referrer_Policy “no-referrer”
X-Frame-Options “sameorigin”

Looks like networking - please check your networking adapter MTU - or event test a lower one.

Thank you for you reply. I figured out what it was.
Turns out that php fpm timed out.

could you advice me where i can find that