Doubled NC client instances in Linux

Linux - Mageia 9 Plasma,
Output from nextcloud -v below:

[maciek@Piotr ~]$ nextcloud -v
MESA: error: ZINK: failed to choose pdev
glx: failed to create drisw screen
failed to load driver: zink
nextcloud.gui.application: Migrating old config from "/home/maciek/.local/share/Nextcloud" to "/home/maciek/.config/Nextcloud"
nextcloud.gui.application: Failed to move the old config directory to its new location ( "/home/maciek/.local/share/Nextcloud" to "/home/maciek/.config/Nextcloud" )
nextcloud.gui.application: Will move the individual files ("Dokumenty_sync.log", "FB+WhatsApp_sync.log", "Fotografie z aparatu_sync.log", "TMP_sync.log")
nextcloud.gui.application: Fallback move of  "Dokumenty_sync.log" also failed
nextcloud.gui.application: Fallback move of  "FB+WhatsApp_sync.log" also failed
nextcloud.gui.application: Fallback move of  "Fotografie z aparatu_sync.log" also failed
nextcloud.gui.application: Fallback move of  "TMP_sync.log" also failed
Nextcloud version 3.11.1git
Git revision c65a8fd6a9d1d436a3ad8a6486117659f0007af2
Using Qt 5.15.7, built against Qt 5.15.7
Using Qt platform plugin 'xcb'
Using 'OpenSSL 3.0.12 24 Oct 2023'
Running on Mageia 9, x86_64

I don’t know why, but very often two instances of the NextCloud client start on their own.
I have declared the start of this client in my KDE desktop environment (Plasma) via the GUI tool of KDE.
However, after two Nextcloud icons appear in the tasks area, after entering the option to set the application autostart (together with the initiation of the KDE session), there are two instances to run.
I delete one, but after rebooting the computer, two instances of the NC client appear again.
This prevents the files from synchronizing properly, of course.
What could be the error and what logs should I send for analysis?

1 Like

Same here, I’m on Endeavour OS (Arch-based), started about a month ago.

Hi,
I have such situation too (KDE X11 / MageIA9).
I went in the KDE system settings / Start and Stop / Automatic Startup (sorry if the terminology is not correct, I have a localized system) : nextcloud was defined twiced.
This has not totally solved the issue, I also removed the autostart setting in the nextcloud client.
So far, it worked, but I do not have tried this much.
Moreover, under the KDE settings, I have removed one but I may have been lucky (it might not have worked if I removed the second one instead). Maybe you should also try to remove both, also in the client, reboot, activate only under the client to make a try…
Hope this helps.

This has maybe to do with duplicate .desktop files.
See: [Bug]: Two instances of Nextcloud Desktop running in parallel · Issue #4661 · nextcloud/desktop · GitHub

And see also: 2280905 – Two nextcloud processes started for one server