[done] NCP 1.51.0 / NC 25.0.3: Twofactor_TOTP 7.0.0 stuck

I am having serious issues with TOTP after I tried to disable and reenable it briefly.

Topic 1) Version 7?

I see I have “Two-Factor TOTP Provider 7.0.0” installed in NC 25.
Looking at the app homepage there should only be v6.4.1: Two-Factor TOTP Provider - Apps - App Store - Nextcloud
What is going on here?

Topic 2) backup codes not generating

When I tried to disable TOTP via UI with removing the checkmark the spinner started going and never finished after a few minutes.
I then did reload the page and the checkmark was gone, so I thought all was fine.
But then I wanted to activate it again to generate a new QR code and again the spinner never stopped.
I also was unable to get a backupcode.

Topic 3: unable to log in
With the presumably reactivated TOTP I tried to log in but only got a generic server issue. This was not much fun as now I could not log in with my admin user.

I was able to disable TOTP from the outside via
sudo ncc twofactorauth:disable ncp totp
so I got back in.

Now I found the following in the logs:

/var/www/nextcloud/apps/twofactor_totp/lib/Provider/TotpProvider.php - line 105:
/var/www/nextcloud/lib/private/Authentication/TwoFactorAuth/Manager.php - line 268:
OCA\TwoFactorTOTP\Provider\TotpProvider->verifyChallenge("*** sensiti ... *")
/var/www/nextcloud/core/Controller/TwoFactorChallengeController.php - line 182:
OC\Authentication\TwoFactorAuth\Manager->verifyChallenge("*** sensiti ... *")
/var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 225:
OC\Core\Controller\TwoFactorChallengeController->solveChallenge("*** sensiti ... *")
/var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 133:
/var/www/nextcloud/lib/private/AppFramework/App.php - line 172:
/var/www/nextcloud/lib/private/Route/Router.php - line 298:
/var/www/nextcloud/lib/base.php - line 1047:
/var/www/nextcloud/index.php - line 36:

Topic 4: unable to remove
I thought that maybe it was a smart idea to completely uninstall TOTP via
sudo ncc app:remove twofactor_totp
Sadly that only brought me:
twofactor_totp could not be removed as it is a shipped app

The weird thing is that for my second “normal” non-admin user all seems to be working fine still and I can log in using TOTP.

Any ideas on how to repait the TOTP for that user?

Please run ncp-report from terminal and share here or via pastebin to provide background and various logs of your installation.

I had so many issues that I finally decided to do a fresh install, so this thread can be closed