Domain Timeout - Lokale IP geht

Hey Leute,

Wenn ich Nextcloud via meinedomain.de aufrufe, dann lädt es im Browser sehr lange.
Bei den Sync Programmen zeigt es mir Time Out an.
Rufe ich es aber über 192.168.177.31 auf, dann funktioniert alles.

Habt ihe eine Idee woran das liegen kann?

meinedomain.de ist eine lokale Domain (nur in deinem Netzwerk) oder löst das deine öffentliche IP Adresse auf?

Prinzipiell solltest du dir Namensauflösung anschauen, ob das schnell geht oder da eventuell was falsch konfiguriert ist. Falls das passt und das über deine öffentliche IP nicht richtig klappt, müsstest du dir näher anschauen, was dein Router macht. Als Abhilfe könntest du die DNS-Einträge in deinem lokalen DNS-Resolver manuell auf 192.168… setzen (manche Router erlauben das, DD-WRT & co).

1 Like

Die Domain wird über Strato gehostet. Meine FritzBox 7490 zeigt keine Fehlermeldung.

falls du ein Linux-System hast, kannst du mit curl -v https://example.org deine Seite abrufen und damit sieht man recht schnell an welcher Stelle es scheitert. Unter Windows musst du mal schauen, ob es das etwas ähnliches gibt, sonst einfach eine Linux-StartCD nehmen.
Ein tracert example.org bzw unter Linux traceroute example.org kann auch helfen, eventuell schickt der Router die Pakete zunaechst an deinen Provider anstatt sie direkt intern zu routen.

1 Like

Ich kann da kein Fehler sehen.:confused:

[details=Summary]> * Rebuilt URL to: linkitup.net/

  • Trying 87.165.86.220…
  • Connected to linkitup.net (87.165.86.220) port 80 (#0)

GET / HTTP/1.1
Host: linkitup.net
User-Agent: curl/7.47.0
Accept: /

< HTTP/1.1 302 Found
< Date: Wed, 16 Nov 2016 08:13:19 GMT
< Server: Apache/2.4.18 (Ubuntu)
< Strict-Transport-Security: max-age=63072000; includeSubdomains;
< Set-Cookie: ocaktfig6xzl=6fb5o1l9u5jt3otcbe5jd8idq0; path=/; HttpOnly
< Expires: Thu, 19 Nov 1981 08:52:00 GMT
< Cache-Control: no-store, no-cache, must-revalidate
< Pragma: no-cache
< Set-Cookie: oc_sessionPassphrase=xrNLbc1FqhIgDSAlPxwPCkE3zMjH6O8dtp2jEXYlDtAYdeDFiThMF7wScFksZ0Plk7wwXUKqaIW395KPXCKMcp8SLg8pgMT0WmkZ%2Bm9xg%2BCsDHM%2BAyWG5yC4BcDuX0Pa; path=/; HttpOnly
< Content-Security-Policy: default-src ‘self’; script-src ‘self’ ‘unsafe-eval’; style-src ‘self’ ‘unsafe-inline’; frame-src *; img-src * data: blob:; font-src ‘self’ data:; media-src *; connect-src *
< Set-Cookie: nc_sameSiteCookielax=true; path=/; httponly;expires=Fri, 31-Dec-2100 23:59:59 GMT; SameSite=lax
< Set-Cookie: nc_sameSiteCookiestrict=true; path=/; httponly;expires=Fri, 31-Dec-2100 23:59:59 GMT; SameSite=strict
< Location: http://linkitup.net/index.php/login
< X-Content-Type-Options: nosniff
< X-XSS-Protection: 1; mode=block
< X-Robots-Tag: none
< X-Frame-Options: SAMEORIGIN
< X-Download-Options: noopen
< X-Permitted-Cross-Domain-Policies: none
< Content-Length: 0
< Content-Type: text/html; charset=UTF-8
<

Der vollständige Befehl sieht so aus (-L follows redirects):
curl -v -L --trace-time example.org

Der Befehl ist sehr praktisch um dem eigentlichen Problem auf die Spur zu kommen, z.B. Verbindung oder SSL-Zertifikat.