"Domain does not point to this server" error on AIO despite correct config

Nextcloud version (eg, 20.0.5): Nextcloud AIO v7.10.0
Operating system and version (eg, Ubuntu 20.04): Lubuntu 23.10

I’m attempting to run the Nextcloud AIO Docker container on a fresh install of Lubuntu.

I’ve confirmed that ports 443 and 3478 (TCP and UDP) are forwarded to the correct device. Port 443 shows as open when checked from canyouseeme.org. I’ve also used dnschecker.org to confirm that port 443 is open on multiple DuckDNS domains I’ve assigned to my home IP.

I’m not using a reverse proxy as far as I’m aware.

When I enter my domain into the validation field under “New AIO instance”, I receive the following error:

Domain does not point to this server or the reverse proxy is not configured correctly. See the mastercontainer logs for more details. sudo docker logs -f nextcloud-aio-mastercontainer

After entering that command on the server, I get:

NOTICE: PHP message: The response of the connection attempt to "http://[DOMAIN].duckdns.org:443" was: 
NOTICE: PHP message: Expected was: 065cbe2fe8d0e7ed45c1b439241979ff556c5799082ded28
NOTICE: PHP message: The error message was: Connection timed out after 10002 milliseconds

I’ve tried this with multiple different domains through DuckDNS.

Any advice on troubleshooting this issue further or what might be causing it?


shouldn’t with AIO your port 8080 response instead of 443 ?
Which ports are open at all?


Thanks for the reply!

My understanding is that the “Nextcloud AIO Interface” should be accessible on port 8080 using the internal IP address of my device. My device is assigned an internal IP of and I’m able to access that interface via Based on the AIO instructions for opening ports, 443 is the port necessary for accessing the actual Nextcloud deployment from an external network. 8080 shouldn’t be necessary unless you want to access the AIO Interface from an external network (unless the instructions are misleading or I’m really not understanding something).

  • 443 TCP/UDP
  • 3478 TCP/UDP (I don’t intend to use Nextcloud Talk, but I opened these ports per the AIO instructions just in case it was the source of this error)

These are the only ports listed as necessary in the AIO setup instructions.

1 Like

Sorry I only saw this thing now:

Can adapt your config with -e SKIP_DOMAIN_VALIDATION=true and confirm?
Just to make sure we are not dealing with a “false certificate” problem?


Huh. I tried that exact method a few days ago and got a certificate error as a result, but I just tried it with a new domain and it appears to be working! Thanks for that suggestion.

Out of curiosity, can you explain what you mean by the “false certificate” problem? Is the issue something to do with getting an SSL cert from Let’s Encrypt?

Nice :slight_smile: !

In some environments, external requests to an internal unofficial certificate throw an error because the requesting app has only official certificates allowed set. If the whole thing has already been secured via a VPN, for example, you can bypass this message with something like SKIP_DOMAIN_VALIDATION=true.

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.