Docker ports assignment on setup

I am trying to set up NextCloud All in One solution on my own server and cannot progress past the Submit domain. I’m sure my machine is currently reachable because I already tested services on the required 443 port. I’ts been days after setting the registrar redirect.

I’m following the installation guide and there is the following paragraph.

“7. Next, type in your public domain that you you’ve got before doing this guide. The interface should help you figuring out which are the exact steps. (Set up DDNS for your domain to point to your public IP, port-forward at least ports 443/tcp, 3478/udp and 3478/tcp to your Linux machine.”

First of all, it has a mismatched parenthesis.

What I don’t understand is I had to use the docker script that sets the exposed ports as “8080” and “8443”, shouldn’t the AIO look for those? Otherwise, I am not sure which of the aforementioned ports 443, 3478 udp+tcp should be redirected to which of the docker exposed ports (do I really have to create a redirect on my same machine?).

It is also strange that the 8080 connection is through httpS while the 8443 cannot be accessed (I rechecked the rules). Is something wrong?

I viewed other posts regarding this topic and could not find an answer or explanation regarding the incongruence. I know I’m not Linux-savy and this start up setup sounds confusing to me, so can someone help me fill the remaining pieces?

Hi, port 443 of your router should be redirected to port 443 of the server running aio.

1 Like

I get that. I really do. It’s simple. But pardon my ignorance. As I already did that (unless i have to redirect inside the linux to docker).

What I don’t understand is how does that work?

Allow me to elaborate: The docker image with the AIO is running with exposed ports “8443” and “8080” (and 80). As I explained, I can connect to the web configuration using the HTTPS to 8080, but not to any of the other ports [First doubt]. So how redirecting to the IP, then have 443 opened make NextCloud work (I am currently running without any service using 443) [Second doubt]. So, does it mean I have to set a reverse proxy like Apache or Nginx so the take the 443 to the 8080? [last doubt].

Thanks for your patience.
Best regards.

AIO spins up additional services that use port 443. so the check and forwarding to 443 is indeed correct

Thanks for clarification. So I don’t have to expose any ports when running the docker image therefore. I’ll try to debug where my problem is and tell if I found.

Thanks for your assistance.
Have a great day.

So this is embarrassing. I knew I set the redirect to my server IP, and I could actually use my domain URL to access the browser interface on the server as mentioned. I checked my registrar URL redirect and the IP was correct as it should, but I then checked the DNS tables and the A registry was pointing to an old IP I don’t know why…