Docker: ONLYOFFICE not reached. Please contact admin

OK guys, I want to implement OO in the VM so that users can choose which one they want (Collabora or OO).

I’m thinking that the best way is to use docker, but when testing on a DO VPS it fails.

What I’ve been doing is basically copying the Collabora setup and changed some of the code, but I’m stuck at the proxying part.

Please help.

UPDATE; I solved it myself.

WHAT did you solve HOW?

@hustenfrei --^ Take another look.

Here’s the result:

I can’t work this out. I have got Collabora working from docker HTTPS but OnlyOffice wont work.
I have Centos 7, separate domain on the same machine for collabora and onlyoffice.
I had OnlyOffice working through http browser, but can’t use that in my NextCloud because it is HTTPS only (I assume that is the problem anyway, from “ONLYOFFICE cannot be reached. Please contact admin” )

Copy certs and various other combinations wouldn’t work for me. I tried using Collabora proxy directives but didn’t really know what I was doing, didn’t work.

I really only need the same kind of instructions as the collabora, for Centos 7, docker, apache and https with a valid cert (Let’s Encrypt).

Solved. I worked out my problem.

Some guides say to use /app/ or /opt/ but neither works I think due to permission errors. Putting the DocumentServer directory in /home/APACHE-USER/ is what worked. I am using Virtualmin which puts all the virtual servers into /home/someuser/

So once I did that and copied the .csr and .key files from /home/USER/ into /home/USER/DocumentServer/data/certs/ and rename them to onlyoffice.csr onlyoffice.key then it loaded through the https:// address. Once Nextcloud OnlyOffice config had the right address and port it all worked fine without any proxy directives or other redirects.

Also be aware that mounting the lib directory didn’t work. I can only mount /data/ and /log/

I only wish OnlyOffice would allow guest editing of documents via public links in the same way collabora does. And also open .odt without conversion.

So my complete working command is something like this

docker run --restart always -i -t -d -p 9981:443 -v /home/onlyoffice/DocumentServer/data:/var/www/onlyoffice/Data -v /home/onlyoffice/DocumentServer/data:/var/www/onlyoffice/Data -v /home/onlyoffice/DocumentServer/logs:/var/log/onlyoffice onlyoffice/documentserver

You mounted data twice!?!?

docker run --restart always -i -t -d -p 9981:443 /
-v /home/onlyoffice/DocumentServer/data:/var/www/onlyoffice/Data /
-v /home/onlyoffice/DocumentServer/data:/var/www/onlyoffice/Data /
-v /home/onlyoffice/DocumentServer/logs:/var/log/onlyoffice /

Collabora allows open .odt without conversion??

@alexis.rosano Yes, Collabora(!) opens .odt without conversion. Collabora is mainly working with open office formats and not with the MS formats.

Onlyoffice however is a the other way round. Not sure however if you need to convert odt files first when opening with Onlyoffice.