Docker Install says "Initializing NextCloudPi for the first time" forever

I just installed armhf version of NextCloudPi and spun it up in a docker container. Logged in, was able to access but made no changes to the NextCloudPI Panel. But when I go to the main page and it reads “Initializing NextCloudPi for the first time Please wait…” as it refreshes the page every few seconds, but it never gets past this stage, it just sits there forever.

I’m relatively new to docker, so I won’t e able to do anything complicated, but I have tried removing just the container and leaving the image, then running the container. As well as deleting both the container and the volume, and creating a new container from scratch.

Does anyone know the cause of this? Could the most recent docker image be broken?

Hello, i am having the exact same issue from raspberry pi 4 with the same architecture.

I have tried the exact same as you and got the same error.

i checked the files inside the container and turns out the index.html that is being served calls an index.php script that apparantly does nothing but:

-set a timer to refresh the page every 2 seconds with javascript and
-start a php session.

But it doesn´t call any other script or anything, and is the only file being served from: http(s)://yourIPaddressOrNOIPddns:(80/443)

is this an intended behaviour? :slight_smile:

Hi there,

Both of you need to be more specific, commands used, provide log and/or terminal output, screenshots, if want/need further assistance.

Check this article https://docs.nextcloudpi.com/en/how-to-get-started-with-ncp-docker/
and search this forum. I found several threads on NCP activation.

Activation can be (extremely) slow on RPI, wait for init done by monitoring ncp.log.

I have the same problem.

System-Info:

NextCloudPi version v1.26.2
NextCloudPi image NextCloudPi_docker_04-06-20
distribution Debian GNU/Linux 10 \n \l
automount no
USB devices sda
datadir /data/nextcloud/data
data in SD no
data filesystem ext2/ext3
data disk usage 35G/1.8T
rootfs usage 5.9G/29G
swapfile /var/swap
dbdir /data/database
Nextcloud check ok
Nextcloud version 18.0.3.0
HTTPD service up
PHP service up
MariaDB service up
Redis service up
Postfix service up
internet check ok
port check 80 open
port check 443 open
IP 172.17.0.3
gateway 172.17.0.1
interface eth0
NAT loopback no

Docker-Info:
Server:
Containers: 2
Running: 2
Paused: 0
Stopped: 0
Images: 5
Server Version: 19.03.12
Storage Driver: overlay2
Backing Filesystem: extfs
Supports d_type: true
Native Overlay Diff: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local
Network: bridge host ipvlan macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 7ad184331fa3e55e52b890ea95e65ba581ae3429
runc version: dc9208a3303feef5b3839f4323d9beb36df0a9dd
init version: fec3683
Security Options:
seccomp
Profile: default
Kernel Version: 4.19.118-v7l+
Operating System: Raspbian GNU/Linux 10 (buster)
OSType: linux
Architecture: armv7l
CPUs: 4
Total Memory: 1.894GiB
Name: openmediavault
Docker Root Dir: /var/lib/docker
Debug Mode: false
Registry: https://index.docker.io/v1/
Labels:
Experimental: false
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false

To monitor ncp’s log, in terminal run:

docker exec -it nextcloudpi tail -f /var/log/ncp.log

If init does not finish, it should tell us at what stage, and why, it is not completing.

image