Docker hub not updateing with the "latest" tag

Updated nextcloud to the new 28.0.2 but when i restarted the app the conatiner fails to pass the version check on dockers image regestry.

I cant find the correct pull image cmd for the new one for 28.0.2.5 any help would be appreciated.

Linux mint running docker PHP_VERSION 8.2.15

please review correct Docker upgrade procedure

Which Docker image? There are many.

official one from nextcloud

https://hub.docker.com/_/nextcloud/tags

using linux mint so im guessing daibian

https://hub.docker.com/_/nextcloud/tags

Then I’m unclear how you updated to v28.0.2 since that image isn’t available yet with v28.0.2.

I’m also unclear how you upgraded Nextcloud without updating the image. The only supported way of upgrading Nextcloud is by bringing in a new image. See the docs @wwe referenced.

using the cmd interface extracting and running occ update within the container.

once updated it worked and loaded but after the restart it wouldn load and i had that error.

still new to the docker scene. upgraded from trunas plugin setup. its been a learning curve but its so much better. lol

didnt relize you needed the docker image as well updated unsure what to do now. im stuck…

the latest on that pull is still only 28.0.1

Please read the Docker updating instructions linked to by @wwe. You should never do a manual update/upgrade in a Docker container.

Short answer (if using Docker Compose):

docker compose pull
docker compose up -d

When you can load the URL in your browser it’s done.

Unfortunately you may have some new obstacles if you manually did stuff in the container somehow.

If still stuck, maybe post your Compose file.

I fixed it with the new docker version that popped up last night. Next time ill wait a few days before updating lol

1 Like