Docker containers not working on raspberry pi

I’ve tried all of these docker images:

  • nextcloud:latest
  • nextcloud:apache
  • nextcloud:fpm
  • ownyourbits/nextcloudpi
  • ownyourbits/nextcloudpi-armhf
  • ownyourbits/nextcloudpi-nc
  • ownyourbits/nextcloudpi-nc-armhf

On my Raspberry A+ v1 as well as on a Zero W v1.1 with Raspbian Stretch Lite 4.14.

All of these images crash right after running and doing a docker container ls -a shows they exit with status 139. I’ve also tried using docker-compose but I still face the same problem.

Note I’ve also tried the non-arm image ownyourbits/nextcloudpi-x86 and that crashes with standard_init_linux.go:190: exec user process caused "exec format error".

Some context:

docker --version
Docker version 18.06.1-ce, build e68fc7a
uname -a
Linux ncp 4.14.79+ #1159 Sun Nov 4 17:28:08 GMT 2018 armv6l GNU/Linux
docker info
Containers: 0
 Running: 0
 Paused: 0
 Stopped: 0
Images: 5
Server Version: 18.06.1-ce
Storage Driver: overlay2
 Backing Filesystem: extfs
 Supports d_type: true
 Native Overlay Diff: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
 Volume: local
 Network: bridge host macvlan null overlay
 Log: awslogs fluentd gcplogs gelf journald json-file logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 468a545b9edcd5932818eb9de8e72413e616e86e
runc version: 69663f0bd4b60df09991c08812a60108003fa340
init version: fec3683
Security Options:
  Profile: default
Kernel Version: 4.14.79+
Operating System: Raspbian GNU/Linux 9 (stretch)
OSType: linux
Architecture: armv6l
CPUs: 1
Total Memory: 481MiB
Name: angel
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Experimental: false
Insecure Registries:
Live Restore Enabled: false

WARNING: No memory limit support
WARNING: No swap limit support
WARNING: No kernel memory limit support
WARNING: No oom kill disable support
WARNING: No cpu cfs quota support
WARNING: No cpu cfs period support
WARNING: No cpuset support

armv6 pis are not supported at the moment. Support might come back when Raspbian Buster arrives.

Ah, which ones are supported then? Not too familiar with pi architectures

everything except for the zero, zero w and rpi 1.

They are too slow for NC anyway

Thanks for the help.

A suggestion, perhaps add a note to about it this? It currently says “Raspberry Pi (all models)”.

You are right, I’ll change it. We used to support them until recently

1 Like