Docker container fails with "AH00534: apache2: Configuration error: No MPM loaded."

Hello all,

I’ve been running the nextcloud docker image (apache) for quite some time without any trouble. I run it on a single docker host and need to move it to a different host. I’ve migrated the data and started the container with the same command I’ve always used, but for some reason, the image exits after about a second with the following error:

AH00534: apache2: Configuration error: No MPM loaded.

Unfortunately, that’s all the output I get.

I have the same image on both hosts (the latest image) and the container starts fine on the old host. I’ve been pulling my hair out trying to figure out what’s going on and all I can find is info on how/when to load MPM modules in the Apache config. That can’t possibly be the issue since I’m using the same image on both hosts with the same data.

Any ideas what might be causing this or where else to look to troubleshoot?

Thanks.

I’m going to follow this thread. I’m not using a docker image for Nextcloud, but I do for Onlyoffice and since I pulled the image yesterday again (checking for updates) it stopped working, meaning that the web server (I believe nginx) in the running docker container is not running.
I was already thinking I became too stupid to use docker, but now I start to believe there is a general issue with docker.

The issue appears to be that the docker host is using the overlay storage driver instead of the devicemapper driver. My original host, where the image works without issue, is using the devicemapper storage driver. The new host is using the overlay storage driver. (The docker info command will show which storage driver is in use.) I’m working on changing that now. If it resolves the issue, I’ll update this thread for anyone that trips over this in the future.

2 Likes

Issue seems to be resolved.

Here’s how I fixed it.

  1. Stop docker

  2. Backup the /var/lib/docker directory

  3. Edit /etc/sysconfig/docker-storage. Change
    DOCKER_STORAGE_OPTIONS="--storage-driver overlay2 "
    to
    DOCKER_STORAGE_OPTIONS="--storage-driver devicemapper "

  4. Start docker (this might take a bit)

  5. Profit

From what I’ve read, this seems to be an issue that only affects CentOS and maybe only CentOS7.

A couple helpful links:

1 Like

Same question!
Thank you very much!:grinning::grinning::grinning::grinning:

I am experiencing this same problem with the Nextcloud 18.0.0 Docker image on CentOS 7. I do not have the option to switch from overlay2 to devicemapper. Even if I could, the Docker docs say that devicemapper support is deprecated and will be dropped soon. Has anyone found an alternative solution to this problem on CentOS? I suppose I could open an issue about it on GitHub.

fanks - it’s me help.