Docker-compose nc, redis

Hello there!
I deployed nextcloud (image: linuxserver:nextcloud, vers. 20.0.4), mariadb and redis using docker-compose on a debian host. See my docker-compose.yml at the end of this post. I connected to the mariadb and logged in. So far, so good. 3 questions:

  1. While I’m sure that the mariadb works fine, I’d like to make sure that redis does it’s job.

I edited the beginning of my nextcloud_config/www/nextcloud/config/config.php as follows:
<?php
$CONFIG = array (
‘memcache.local’ => ‘\OC\Memcache\Redis’,
‘memcache.distributed’ => ‘\OC\Memcache\Redis’,
‘memcache.locking’ => ‘\OC\Memcache\Redis’,
‘redis’ =>
array (
‘host’ => ‘redis’,
‘port’ => 0,
‘timeout’ => 0,
‘dbindex’ => 0,
),

I am wondering if the syntax is ok like this. The official nextcloud docs use one “” only :
‘memcache.distributed’ => ‘\OC\Memcache\Redis’,

The log of my running stack shows pages full of

Is that supposed to look like this? How may I get confirmation, that redis works?

  1. I would like to make sure that Upload filesize and timeout are set properly. I have read, that I need to set some variables in [/etc/php7/php.ini] and [/etc/php/conf.d/zzz-custom.ini]. I am refering to the variables
    change client max body size
    upload_max_filesize
    post_max_size
    But I am not able to locate these directories and files. Did they move? Could you please help me out?

  2. I’d like to download and enable the Community Document Server. But my attempt to do so fail with the following error messages:

    Error PHP Out of memory (allocated 12582912) (tried to allocate 378292112 bytes) at /config/www/nextcloud/lib/private/Installer.php#287
    Error settings GuzzleHttp\Exception\ConnectException: cURL error 28: Operation timed out after 120000 milliseconds with 203445820 out of 378283893 bytes received (see https://curl.haxx.se/libcurl/c/libcurl-errors.html)

Has this something to do with the issues described in point 1 or 2? How to fix?

Thank you very much in advance. Can’t wait to get Nexcloud properly up and running!


version: “2.1”
services:
nextcloud:
image: ghcr.io/linuxserver/nextcloud:latest
container_name: nextcloud
environment:
- PUID=1000
- PGID=1000
- TZ=Europe/Oslo
- REDIS_HOST=redis
- NEXTCLOUD_TRUSTED_DOMAINS=nextcloud.subseascanning.com
volumes:
- /var/lib/docker/volumes/nextcloud_config:/config
- /var/lib/docker/volumes/nextcloud_data:/data
ports:
- 21005:443
depends_on:
- mariadb
- redis
restart: always
mariadb:
image: ghcr.io/linuxserver/mariadb:latest
container_name: mariadb_nc
environment:
End - PUID=1000
- PGID=1000
- TZ=Europe/Oslo
- MYSQL_DATABASE=nextcloud
- MYSQL_USER=root
- FILE__MYSQL_PASSWORD=/home/dejhost/compose/setup/mysql_password
volumes:
- /var/lib/docker/volumes/mariadb_nc_config:/config
ports:
- 21006:3306
restart: always
redis:
image: redis:latest
container_name: redis_nc
ports:
- “21001:6379”
restart: always

Nobody? Or do I miss the obvious?
Thanks in advance!