Disable https redirect on nextcloud snap

Hello,

I installed nextcloud as a snap. No I want to enable a reverse proxy as I want to host another service on the same server.

For this i changed the port of the nextcloud installation to 80->81, 443->444. I previously had the https-enable letsencrypt setup. For the reverse proxy I ran

nextcloud.disable-https

Now when I access 127.0.0.1:81 I get still redirected to https://127.0.0.1/, but the certificate validation fails.

Any tips on how to remove the redirect within the snap?
Thanks for helping!

My fault: a simple

snap stop nextcloud & snap start nextcloud

did the trick.