Directory disappeared

Hi All

So I’ve has NC15 running on a Rasperry Pi for a few months now.

This morning I wanted to upload some pictures and it seems my photos folder has disappeared.
I don’t believe its been deleted.

to try and recover I ran fschk on the drive, there was some errors and I believe they were fixed, but I still cant see the directory (terminal or web).

The files are clearly still there, as the disk reports loads of disk usage
“root@nextcloudpi:/# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 916G 329G 541G 38% /mnt”

Filesystem is ext4

I tried my google fu, but I’m now totally lost.

Thanks heaps for any help.

If you have terminal access to the RPi, go to the folder, where your user data is stored on and perform a

du -hs *

this will show you, which folder holds how much data. If your NC data folder is located on that external storage device, which is what the mountpoint /mnt implies, your command would look like this:

du -hs /mnt/data/*

If your setup is different then you will have tp provide more information about your setup.

Hi Budy

You’re a genius!!!
Thank you. Fro whatever reason the photos directory moved into the Notes directory, all off the 180G.
Should have thought about tracking it down the way you described, but I was way to caught up in the fact that the folder disappeared. Not sure how that happened, doesn’t matter now really.

Getting onto sorting backups, right now!!!


Glad to hear that you solved your issue. Please consider marking this thread as solved.