Desktop-client for Ubuntu 20.04 LTS not available

Why is not desktop-client available for Ubuntu 20.04 LTS???
There is no PPA for it.
I am really disappointed how it can be possible. Most popular linux distro and it is not supported???
https://launchpad.net/~nextcloud-devs/+archive/ubuntu/client

E: The repository 'http://ppa.launchpad.net/nextcloud-devs/client/ubuntu focal Release' does not have a Release file.

When will it be available?
Thank you.

1 Like

Ubuntu 20.04, as in… the one that was released yesterday? It probably takes a few minutes to set up the PPA for the new version.

2 Likes

I hope it will be available soon.

https://packages.ubuntu.com/focal/nextcloud-desktop
https://packages.ubuntu.com/focal/nautilus-nextcloud

sudo apt install nextcloud-desktop nautilus-nextcloud

:grinning:

1 Like

Thank you !

1 Like

I tried installing from the repos and got the following:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nextcloud-desktop : Depends: libnextcloudsync0 (= 2.6.2-1build1) but 2.7.0-20200326.032614~focal1 is to be installed
Recommends: nextcloud-desktop-doc but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I did a fresh install of 20.04 at the beta stage.

I solved installation for the moment this way.
I have downloaded Linux Appimage
https://download.nextcloud.com/desktop/releases/Linux/latest
Filename is Nextcloud-2.6.4-x86_64.AppImage.
Rightclick and set permition to “run” application.
Doubleclick for start installation.
Connecting to mu Nextcloud server.
After that:
sudo apt install nextcloud-desktop nautilus-nextcloud
Desktop client installed.
Hope it helps.

I am using the app image, but would prefer it to be in repo, auto start isn’t working and it is just clunkier. But it sounds like you did not have the same dependency errors as I had?

I had something messed up during my initial install attempt while in beta. I had to apt autoremove and there were some mismatched packages. I reinstalled and all is well.

Why don’t you try the Flatpak?
https://flathub.org/apps/details/org.nextcloud.Nextcloud

@Wesley_Stout I have also problem with autostart. It does not work for me. Did you resolve how to fix autostart of client? If you did, please explain how to fix it?
Tutorial is welcome.
Thank you.

@Boki4d flatpak is not way for me. I had Ubuntu 18.04 before and PPA installation of client worked fine.

1 Like

I’am also using the appimage in the moment but the ppa version would be far more convenient. So I hope it will be available soon. There is also a ticket open at the github: https://github.com/nextcloud/desktop/issues/1911

The current in-repo version is also current and can get you through until the ppa becomes available and for me is much preferred over a ppa.

I did not get the appimage to autostart, the version in the repos works excellent for me, I had some hanging issues when I initially tried to install from a ppa for 19.10.

the ppa was updated yesterday and now contains focal! However, auto start was broken for me since there was a strange path included inside ~/.config/autostart/Nextcloud.desktop. After changing it to Exec=/usr/bin/nextcloud it was working fine