Desktop client cannot find owncloud/status.php?

My linux desktop client cannot connect to a NextCloud server behind a nginx proxy. But when I sign it via the webpage it works perfectly.

The client works fine if I try to login into the server’s IP/domain directly but the client throws this error when trying to connect over the proxied domain.

The NextCloud folder on my server has been renamed to “files.”

There is a status.php in the NextCloud server’s directory but no owncloud/status.php.

Why is the desktop client trying to look into an OwnCloud subdirectory on the server? And why is it only doing it when accessing through the proxied domain?

Facing the same issue. Did anyone find any solution to it? thanks

Same issue here - no solution found, yet? How did you handle it, @dnte1020?

I haven’t found a solution to it yet.

My work-around for now is a custom entry in my hosts file.

Hi, I don’t really know why, but it started to work for me again. :thinking:

Same problem here…
Server version 11.0.2 (docker), client 2.2.4 on Win10
Any news on the issue?
Thanks

Hi I’m having the same problem over here? Someone found out what’s the problem yet?

hi there. same problem.
I solved it with this workaround.

  • create symbolic link between owncloud and netxcloud
    sudo ln -s /etc/apache2/sites-available/owncloud.conf /etc/apache2/sites-enabled/owncloud.conf
  • create “owncloud.conf” in /etc/apache2/sites-available/
    sudo nano /etc/apache2/sites-available/
  • copy this text inside “owncloud.conf”

Alias /owncloud “/var/www/owncloud/”

<Directory /var/www/owncloud/>
Options +FollowSymlinks
AllowOverride All

Dav off

SetEnv HOME /var/www/owncloud
SetEnv HTTP_HOME /var/www/owncloud
Satisfy Any

restart server
sudo service apache2 restart

hope it helps !

hi there

faced same problem, you can do it like @txsastre showed it or you can just type in the full url:

http(s)://localhost/status.php or http(s)://localhost/nextcloud/status.php

depending on the installation.

cheers