Desktop client broken on GNOME

The Desktop client fails to start for me. It works sometimes when I start it manually but the autostart never works. The Nextcloud process will be running but the window will fail to render and it won’t actually sync anything. I got error messages saying the gtk-canberra-module was missing.

I’ve reproduced this bug on Fedora, OpenSuse and BlendOS having tried the flatpak on each distro as well as OpenSuse’s and Fedora’s native packages.

2 Likes

I just found this linked with Nvidia drivers:

Thanks, but none of the three boxes I had this on has an nvidia gpu :frowning:

And did you try to install this gtk-canberra-module?

Just trying a few obvious things to get a quick solution for your, if everything else does not help, there is eventually the bug tracker…

Same here: Ubuntu 23.10, gnome.
No Nvidia, all canberra libs (that i found) installed.

@J-Kappes did you create an issue in the bugtracker, yet?

No, I have not.

I think I have the same issue. I can not add multiple users, because of the nextcloud client GUI not rendering and reacting on input keys proberly.
Autostart and syncing does work on my system.

On Fedora Silverblue it looks like this: (I added red arrows where I miss graphics)

On Windows 10 it looks like this:


Detailed system info of my linux machine:

Systemdetailsbericht


Berichtdetails

  • Erstellungsdatum: 2024-03-24 13:06:19

Hardware Information:

  • Hardware-Modell: ASUS KCMA-D8
  • Speicher: 15,5 GiB
  • Prozessor: AMD Opteron™ 4256 EE × 8
  • Grafik: NV106
  • Festplattenkapazität: 250,1 GB

Software Information:

  • Firmware-Version: 18ee55c
  • Name des Betriebssystems: Fedora Linux 39.20240320.0 (Silverblue)
  • Betriebssystem-Build: (null)
  • Betriebssystem-Typ: 64-bit
  • GNOME-Version: 45.5
  • Fenstermanager: Wayland
  • Kernel-Version: Linux 6.7.9-200.fc39.x86_64

Nextcloud Client from flathub Version 3.12.2

I found a command which fixed my issue. :smiley:
Check this thread for the details: