Desktop Client Black Screen after Server Connection


#1

I have an issue whereby Nextcloud client(s) inc the latest versions and older ones show a black screen after agreeing to the self-signed certificate, this black screen is all I see. Anyone else experienced this or have any ideas? The HTTPS interface works fine as does Owncloud’s 2.5 client.

Here are the screenshots:

After agreeing to the self-signed certificate, this black screen is all I see. The system is still responsive but I can only go “back”.

This is the OwnCloud Client version showing both connections, but reporting unsupported Nextcloud server.


#2

Did you ever find a solution to this problem?


#3

Same problem on Windows 7 Enterprise SP1. Rolled back to older version


#4

It seems to just be a black screen with all links and fields available, you just can’t see them. What I did was move the mouse around until the cursor changed to allow me to input data. I typed the username, hit tab and then typed the password and pressed Enter and it let me in.


#5

I solved a problem with black screen in the Connection Wizard in the Ubuntu desktop client, version 2.5.1-20181204.111806~bionic1 from ppa:nextcloud-devs/client.
It appeared when clicking “Next” after filling in the server address. Seems like the OP:s case. (Server has a letsencrypt cert, so no agreeing of self-signed cert needed.)

To troubleshoot I started nextcloud from command line like this to enable logging:
nextcloud --logwindow --logdebug
This showed an error
QOpenGLFramebufferObject: Unsupported framebuffer format.
when clicking “Next”, which hinted at a graphics handling problem.
I am running lubuntu 18.04.1 inside a VirtualBox. Problem was caused by “Enable 3D Acceleration” in the Virtual Machine settings. After removing that, it now works.


#6

My problem is with a physical machine… but then again I’m accessing it with Remote Desktop (RDP). Same problem? Is there a way to circumvent that?