Desktop client app password


I want to use an app password for my desktop-clients.

The issue is that the desktop-client is not asking for password by itself but is opening a browser windows to log in and to approve access. That is not what I want.

How can I force the desktop client to

  1. ask by itself for pw
  2. use then provided app pw


Is there a specific reason why you want to use a manually generated App Password instead of the standard login via Login Flow? I’m asking because Login Flow is actually the preferred way of connecting client apps, as it automatically generates a unique app password for each client.

However, to answer your original question: There should be a link called “Alternative Login via App Password” or similar below the “Login” button in the browser window.

Bildschirmfoto vom 2024-07-07 12-05-45

My desktop-client is logged out every shutdown of my OS. I don’t know why, but this happens since the installation of a news OS (Opensuse Tumpleweed) on my PC.

When I am starting a desktop session the client opens a browser window every time and is asking for approval.

I found no solution to keep the client logged in as under Windows or other Linux.

The Browser stays logged in but not the desktop client. With an app password I hope I can get a “silent” log in of the client.

Or I can force the client not to be logged out at system shutdown. Then no app password is needed.


I’m not sure what’s causing this, as I’ve never had this problem on either Linux or Windows, but I honestly doubt that manually creating an app password will solve this…

On Linux, it may have something to do with your desktop environment’s keyring. Check if the following packages are installed on your system and/or search for the corresponding keywords here, in the forums, on GitHub and on the wider web…

GNOME: gnome-keyring libsecret and libgnome-keyring

KDE Plasma: kwallet (additional packages may be required, not sure)

Windows: No idea what might be causing the problem.

1 Like

I am running KDE but not using KWallet. I have another password manager in use which is also available for other platforms.

Setting an app password is not solving the issue.

Cookies and/or passwords are deleted (or cannot even be saved) every session of the desktop client.

You don’t need to “use” Kwallet as your password manager, but there must be some key-manager/keychain installed on your system in order for the Nextcloud client to be able to store its credentials.

I think so, but it must be a tool by the client itself, not from a third party. Nobody can expect hat a user is using the right tool in every case.

There is a cookies0.db file in the configuration folder. Maybe …

I don’t want to put much more effort in this issue. It is not worth the time …

It is as it is now.


Did you download the AppImage from nextcloud directly? If so you could maybe try to install the package from the openSUSE repos via the package manager of your distro…

I don’t use Plasma or openSUSE, so I probably won’t be able to help you any further anyway…

However, in my experience, when installing the client from a distribution’s repository using the distribution’s package manager, the necessary dependencies are usually installed automatically. For example, on Debian libqt5keychain1 is a dependency of nextcloud-desktop, the same is true for Ubuntu and Fedora. So maybe this is worth a shot if you haven’t tried already.

This lib is installed.

I recently tried a virtual Ubuntu with same result as for Opensuse.

Something must be changed.

Yeah, maybe, or maybe Kwallet or another secrets manager like gnome-keyring is still necessary for it to work. I’m using Fedora (Workstation GNOME Edition) and I never had to do anything manually. Gnome-keyring was already installed by default as part of the GNOME desktop, then I did “dnf install nextcloud-desktop” and it worked right from the start and ever since.

So if you don’t get any more answers here maybe also try to search the forums and GitHub for hints. There are quite a few threads and issues about the client not remembering credentials, or maybe you can also ask your question here: