Deck card description not saving

I am on Nextcloud Hub 7 28.0.3 and over last few weeks I have noticed that I am not able to save a Deck card description. It will occasionally work but 90% of the time it does not save. Upgrade to 28.0.3, sever reboot, and fixing database missing indexes has not fixed this issue.

Server config:
Type: mysql
Version: 8.0.36
Size: 1.2 GB

PHP Version: 8.1.2
Memory limit: 2 GB
Max execution time: 3600
Upload max size: 2 GB
OPcache Revalidate Frequency: 1

Extensions: Core, date, libxml, openssl, pcre, zlib, filter, hash, json, Reflection, SPL, session, standard, sodium, cgi-fcgi, mysqlnd, PDO, xml, apcu, bcmath, bz2, calendar, ctype, curl, dom, mbstring, FFI, fileinfo, ftp, gd, gettext, gmp, iconv, igbinary, imagick, intl, ldap, exif, msgpack, mysqli, pdo_mysql, Phar, posix, readline, redis, shmop, SimpleXML, smbclient, sockets, sysvmsg, sysvsem, sysvshm, tokenizer, xmlreader, xmlwriter, xsl, zip, memcached, libsmbclient, Zend OPcache

To help figure out where the issue is, on the top left corner of the card where it says “Modifed: xx ago” - what does it say?

ive been seeing this myself a bit this morning, havent done much research into logging or anything but for mine it shows as “modified : seconds ago” but it seemed to stay like this for about a minute.

i also just opened one, added text and it remained saying “modified: 6 hours ago” for a number of minutes now. then when i click the x it doesnt save, but then i just opened another one and added text and it saved right away after entering text. very odd