Deck App: Coudn't install latest version


Afer update from Nextcloud 20.0.4 to Nextcloud 20.0.5 previously installed Dock App was disabled. I’ve activated it again and wonderd about warning about incompatible version.

After reenabling App it shows that App version 0.4.1 was installed (for Nextcloud 12 ??). I tried to remove and reinstall app from store, but could only install these outdated version.

I also tryed to manuell install the latest deck app version directly from GitHub. It worked, but I couldn’t use the deck app, because it seems that database tables / content was also damaged.

So, I decide o restore a backup … hope that will help.



Error in Nextcloud Log
[no app in context] Error: InvalidArgumentException: Notifier Deck (id: deck) is not considered because it is using the old way to register. at <>

  1. /var/www/nextcloud/apps/deck/lib/AppInfo/Application.php line 122
    OC\Notification\Manager->registerNotifier(Closure {}, Closure {})
  2. /var/www/nextcloud/apps/deck/appinfo/app.php line 26
  3. /var/www/nextcloud/lib/private/legacy/OC_App.php line 289
    require_once("/var/www/nextcl … p")
  4. /var/www/nextcloud/lib/private/legacy/OC_App.php line 171
    OC_App::requireAppFile(OCA\Deck\AppInfo\Application {})
  5. /var/www/nextcloud/lib/private/legacy/OC_App.php line 131
  6. /var/www/nextcloud/lib/base.php line 993
  7. /var/www/nextcloud/index.php line 37

POST /settings/apps/disable
from by ncp at 2021-01-16T20:06:44+00:00

I have the same problem, starting few days ago with fresh Nexcloud 20.0.5 (Cloudron package) - first install of deck from appstore and old version 0.4.1 installed as newest.

Same here, native installation from zip file.

Can confirm the situation. I just migrated from Nextcloud 20.0.5 to a docker-based installation without transferring the apps. The migrated docker app stood at v0.4.1 even when trying to run docker-compose exec --user www-data app php occ app:update deck. Force-activating destroyed my entire calendar storage, so I had to go back to a backup state and manually extract the latest version of the app under custom_apps.