Debug Openstack external storage error

external_storage

#1

Hi,

how can I debug the external storage error? I have red squares:

For example, here’s the output of chrome > inspect > network (/index.php/apps/files_external/globalstorages/1?testOnly=true):

I can see there’s an “system” error with code=1, how can I have more details? Is it a credentials issue?

Thank you :relaxed:
Florian

Hosting : OVH VPS SSD 1 https://www.ovh.com/fr/vps/vps-ssd.xml
Nextcloud version : 12.0.3
Operating system and version : Ubuntu 16.04
Apache or nginx version : 2.4
PHP version : 7.1


#2

Hi!
Have you figured this out? I’m also trying to mount Swift storage from OVH. Without luck.
I’m certain I’m providing correct configuration values - I tested them in the command line. I wasn’t sure if nextCloud needs Tenand Id or Tenant Name - I have tried both however, and both didn’t work.


#3

Hi !

Sadly I think it’s not working with OVH…

I tried a free Amazon S3 instance to be sure, and the S3 is working, so I dropped OVH for Amazon.

But it still doesn’t meet my requirements, nextcloud seems very slow to open any folder on external S3 storage, and I reached the 20k requests per month in like 5-7 days, so I think something is wrong…

I’m waiting a couple of month for this to be more stable

Cheers
Florian


#4

Be sure to test Nextcloud 14 beta’s and if there are still issues, help get them fixed before the release!