Debian 9 PHP version too old for Nextcloud 16

#1

Debian 9 PHP version (7.0.33-0+deb9u3) too old for Nextcloud 16. If Nextcloud 16 can reduce PHP version requirement that would be helpful.

#2

false …

php7.2 available.
php7.3 available.

You just need to update.

Nextcloud don’t need to reduce requirement, you need to update to newer/stronger/secure php version.

as simple as:

apt-get install php7.2 php7.2-common php7.2-cli php7.2-fpm

check if version is well installed

php -v
should get

PHP 7.2.x ( i used 7.3, dont know witch 7.2 is latest )

a2dismod php7.0
php7.0 extinction

a2enmod php7.2
php7.2 enabling

service apache2 restart

Be sure check installed PHP modules or reinstall them all
apt-get install libapache2-mod-php7.2 php7.2-cgi php7.2-cli php7.2-common php7.2-curl php7.2-gd php7.2-imap php7.2-intl php7.2-json php7.2-ldap php7.2-mbstring php7.2-mysql php7.2-opcache php7.2-pspell php7.2-readline php7.2-soap php7.2-xml

of course, some twitching for the ini will be needed
/etc/php/7.x/apache2/php.ini
/etc/php/7.x/cgi/php.ini
/etc/php/7.x/fpm/php.ini
/etc/php/7.x/mods-available/php.ini

1 Like
#3

The usual pleasant response from the Nextcloud community.

Debian 9 Stretch does not have PHP 7.2 in official repository.

https://packages.debian.org/stretch/php

PHP 7.2 can be installed but it is done using repositories other than official.

#4

false.

Backport in sourcelist.

#5

to mitagate my answer, this is normal, 7.2 is not a real package, as it is now 7.3
https://tracker.debian.org/pkg/php7.3

#6

@stratege1401 is right about backports. Some don’t use backports though for the same reason that use Debian.

On another note the Nextcloud community (both here and GitHub) is usually like this, curt and rude, for those reading this in the future. It’s the MO of the project and its disappointing.

#7

But “please rewrite your work to be compatible with an unsupported version of PHP for perceived compatibility with my distribution” is perfectly acceptable. And despite having received a correct answer within an hour, you complain about the tone.

#8

no time to be gentle, nice and used a flowrish language here or in any forum. Fast, acurate and next. You can’t take a quick normal answer with a pre-engineered solution, too bad !!!

you ask to have a php 7.0 support, witch is no more planned due to obsolescence:
Current Stable PHP 7.3.5, old stable is 7.2.19.

Does nextcloud need to address now deprecated php, why not. So, what about having php 5. or even php 3.2 or even older … see my point.
I prefer nextcloud to focus on real-live php support !

Php7.0 is not even any more available or supported on php.net …

Maybe you need a special window 3.1 update ?? <-- Just in case you feel my arsh tone here, this is a joke.

#9

The Nextcloud community at their finest above…

It is total oversight to release software that doesn’t take Debian Stable into account.

#10

In a few weeks, the actual Debian stable will become the old-stable. My bet is on July 2019. The 17th maybe… Clearly around.

#11

Official repos are many times years behind. When I started to use linux, I didn’t want to use any other repos than officials. Finally I got tired to wait new versions and started to use other repos too. That was propably the best decision I have made in the world of Linux.

#12

Arch is my desktop. One doesn’t use Arch for servers.

#13

my best decision was to start using docker. (to get out of this distro/package dilemma.)

2 Likes
#14

Why not Arch for server ? I manage my own server with nextcloud and other services for few years, and it’s on Arch. No problem at all.

It’s better to use the system you know, the one you use daily, than another one you don’t really know and you complain about.

#15

I need to learn to use docker first. I know only some basic things about docker. But you’re right. It feels very handy. Maybe it will be my best decision. :wink:

#16

One’s high self-esteem should neither lead to bending the facts nor to ignoring the NC Community Guidelines

This seems to be debatable …

  1. https://tracker.debian.org/pkg/php7.0
  2. https://tracker.debian.org/pkg/php7.1
  3. https://tracker.debian.org/pkg/php7.2
  4. https://tracker.debian.org/pkg/php7.3

AFAIK there is PHP 7.0 for Debian 9 stable and PHP 7.3 in buster (testing) but no stretch-backports.

Politeness could help, I presume.

3 Likes
#17

One may refer to the a.m. issue for background information on the PHP evaluation in the Nextcloud team.

#18

The culprits in this case are the people at Debian who made Ondrej Sury refrain from creating backports of newer PHP releases for Debian Stretch. Here you can read more about it:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=893700
https://lists.debian.org/debian-backports/2013/12/msg00057.html

Anybody complaining that PHP 7.0 which is EoL and Debian Stable not providing something newer through backports (even if the person does all the PHP packaging for Debian and Ubuntu!) should “thank” the Debian folks for not having anything newer available on their repositories. I am not really impressed by them throwing people who could do it under the bus.

1 Like
#19

This is why I keep my current system on NC 15 for now, until Debian Buster is released.
It’s great that a platform as Nextcloud gives it’s users this choice: running a major version branch which matches your configuration, within support.

Perhaps as a side note for postgresql users on Debian Stretch, when upgrading to Buster:
https://www.debian.org/releases/testing/amd64/release-notes/ch-information.en.html#postgresql-reindex

#20

Nextcloud 15.x is still supported, you can still use it in debian 9. It’s normal that newer version of Nextcloud are done with currently supported php versions. Debian is not linux, I don’t think it should be taken in account more than orther linux distro. If you say it’s used a lot for servers… Centos 7 also and it has still php 5 in official repos, so… ? :wink:

1 Like