(Debian 12) Nextcloud Client using 99%+ of CPU and becomes unresponsive

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): Nextcloud 27.1.2
Operating system and version (eg, Ubuntu 20.04): Debian 11
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.56-1
PHP version (eg, 7.4): PHP 8.1.23-1

The issue you are facing:
I have a Debian 12 latop with KDE Plasma (X11) and I installed Nextcloud-Desktop 3.7.3-1 from the Debian 12 repo. The client uses 99%+ of my CPU at all times. It is completely unresponsive and the only way I can close it is to kill the pid from terminal.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Boot up laptop and login.
  2. It works fine on my other laptop running Debian 11

The output of your Nextcloud log in Admin > Logging:

[webdav] Error: Sabre\DAV\Exception: Unknown error while seeking content at <<closure>>

0. /var/www/nca.zaks.web.za/apps/dav/lib/BulkUpload/MultipartRequestParser.php line 129
1. /var/www/nca.zaks.web.za/apps/dav/lib/BulkUpload/BulkUploadPlugin.php line 71
2. /var/www/nca.zaks.web.za/3rdparty/sabre/event/lib/WildcardEmitterTrait.php line 89
3. /var/www/nca.zaks.web.za/3rdparty/sabre/dav/lib/DAV/Server.php line 472
4. /var/www/nca.zaks.web.za/3rdparty/sabre/dav/lib/DAV/Server.php line 253
5. /var/www/nca.zaks.web.za/3rdparty/sabre/dav/lib/DAV/Server.php line 321
6. /var/www/nca.zaks.web.za/apps/dav/lib/Server.php line 365
7. /var/www/nca.zaks.web.za/apps/dav/appinfo/v2/remote.php line 35
8. /var/www/nca.zaks.web.za/remote.php line 172
   require_once("/var/www/nca.za ... p")

POST /remote.php/dav/bulk
from by zeev at 2023-10-19T15:57:45+00:00

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'REDACTED',
  'passwordsalt' => 'REDACTED',
  'secret' => 'REDACTED',
  'trusted_domains' =>
  array (
    0 => 'REDACTED',
  'datadirectory' => 'REDACTED',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'REDACTED',
  'dbname' => 'REDACTED',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'REDACTED',
  'dbpassword' => 'REDACTED',
  'installed' => true,
  'default_phone_region' => 'ZA',
  'mail_from_address' => 'no-reply',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => 'REDACTED',
  'mail_smtphost' => 'REDACTED',
  'mail_smtpport' => '465',
  'mail_smtpauth' => 1,
  'mail_smtpname' => 'REDACTED',
  'mail_smtppassword' => 'REDACTED',
  'maintenance' => false,
  'loglevel' => 2,
  'app_install_overwrite' =>
  array (
    0 => 'calendar',
    1 => 'side_menu',
    2 => 'integration_libretranslate',
    3 => 'holiday_calendars',
    4 => 'maps',
  'memories.exiftool' => '/var/www/nca.zaks.web.za/apps/memories/exiftool-bin/exiftool-amd64-glibc',
  'memories.vod.path' => '/var/www/nca.zaks.web.za/apps/memories/exiftool-bin/go-vod-amd64',
  'memories.vod.ffmpeg' => '/usr/bin/ffmpeg',
  'memories.vod.ffprobe' => '/usr/bin/ffprobe',
  'theme' => '',
  'updater.secret' => 'REDACTED',

The output of your Apache/nginx/system log in /var/log/____:


[Thu Oct 19 17:57:44.755286 2023] [proxy_fcgi:error] [pid 180406] (70007)The timeout specified has expired: [client] AH01075: Error dispatching request to : (reading input brigade)

access.log - - [19/Oct/2023:17:57:25 +0200] “PROPFIND /remote.php/dav/files/zeev/InstantUpload HTTP/1.1” 207 1430 “-” “Mozilla/5.0 (Linux) mirall/3.7.3git (Nextcloud, debian-6.1.0-12-amd64 ClientArchitecture: x86_64 OsArchitecture: x86_64)” - - [19/Oct/2023:17:57:28 +0200] “PROPFIND /remote.php/dav/files/zeev/InstantUpload/Redmi%2010C HTTP/1.1” 207 1636 “-” “Mozilla/5.0 (Linux) mirall/3.7.3git (Nextcloud, debian-6.1.0-12-amd64 ClientArchitecture: x86_64 OsArchitecture: x86_64)” - - [19/Oct/2023:17:57:30 +0200] “PROPFIND /remote.php/dav/files/zeev/InstantUpload/Redmi%2010C/Downloads HTTP/1.1” 207 5744 “-” “Mozilla/5.0 (Linux) mirall/3.7.3git (Nextcloud, debian-6.1.0-12-amd64 ClientArchitecture: x86_64 OsArchitecture: x86_64)” - - [19/Oct/2023:17:57:30 +0200] “PROPFIND /remote.php/dav/files/zeev/InstantUpload/Redmi%2010C/Inspired HTTP/1.1” 207 3157 “-” “Mozilla/5.0 (Linux) mirall/3.7.3git (Nextcloud, debian-6.1.0-12-amd64 ClientArchitecture: x86_64 OsArchitecture: x86_64)” - - [19/Oct/2023:17:57:34 +0200] “POST /remote.php/dav/bulk HTTP/1.1” 408 774 “-” “Mozilla/5.0 (Linux) mirall/3.7.3git (Nextcloud, debian-6.1.0-12-amd64 ClientArchitecture: x86_64 OsArchitecture: x86_64)”

1 Like

Hmm, looked up your error and got a lot of results.


After changing Timeout settings and child settings for Apache and PHP I eventually gave up.

So I manually copied the files on the server that were not on the laptop over to the laptop. Then I manually copied the files on the laptop that were not on the server over to the server.

I then went to user files folder on the server and ran

chown -R www-data:www-data *

I then went to the webroot folder under /var/www for the vhost that I had configured for Nextcloud.

I typed

sudo -u www-data php occ files:scan [username]

I then started up Nextcloud Desktop, and it had 27 files to sync??? But it locked up on the first file.

So I figured that there was an issue with the files either on my laptop or on the server.

Since occ never returned any errors when scanning the files, I assumed it was on my laptop. Moved the entire contents (including hidden files and folders) to another folder. (Just in case - We always make backups.)

Started up Nextcloud Desktop. Took about an hour but it all Synced fine and didn’t overload my CPU.

1 Like

I placed a small pdf (less than 1MB) in my nextcloud folder and now the problem is back. It won’t upload it to the server, and CPU usage maxes out. So the problem is related to files being uploaded…

So the problem is with your laptop as opposed to the Nextcloud server, yes?

If so, perhaps try using the flatpak packaging. Could be that your computer is struggling because of it’s own issues. I’m not sure. What are the specs, including network speed? And what are the specs of your server?

According to the logs on the server it is related to proxy_fcgi… but if I delete everything off the laptop, and then sync, it works fine. Only when I add a file on the laptop, then it bogs out.

It’s an i5 Gen3, 8GB RAM, SSD.

The server is an old HP Mini Server.

I did try again this morning, and run top on the desktop and the server. PHP hits 40% on the server when Nextcloud hits 100% on the laptop.

I am going to try the flatpak as you suggested…

Strange though, my i5 2nd Gen is running it fine in Debian 11.

2 posts were split to a new topic: Desktop client using 99% cpu