Dashboard Calendar Widget Issue - It goes to a page that never loads

Hi All,

I have the latest stable NextCloud and I have this issue for the last 3 versions.

If I go directly to the calendar, I have no problems. However, if I click on the Calendar Widget on dashboard–regardless of clicking on adding a new event (when no event on calendar) or clicking on an upcoming event–it takes me to a page that never loads and after many minutes browser asks if I want to terminate the request because it does not load.

I tried it with different browsers, mode security off and on. Also I installed a fresh new NextCloud. The issue is the same.

Then I went and updated an exising old installation without this issue. Same issue starts there as well.

Today I was hoping that the new version will fix this issue like the issue we had with PDF files, but it did not get fixed, so I came to write this here.

Any ideas?


Any ideas?

I am also getting this error on Chrome and Edge, Firefox seems to work ok, so it must be a redirect or popup problem with the browsers, can you try this and confirm?

You are right. It works on Firefox but not on Chrome, which is the most popular browser. I even tried in Incognito mode of Chrome and result is a fail.

Thank you for getting back to me Canadamcpherson, I am hoping and admin is watching this, can someone else test this also for us?

Have you tried adjusting security settings in browsers? I allowed redirects but to no avail :frowning: Looked for errors in developer mode and not showing anything unusual.

It just seems that the developer is using Firefox and never tried it in Chrome.

Thanks Canadamchperson,
Have you managed to solve the problem in your chrome/edge browser? Is it only us that is getting this issue?
I am using Edge Version 92.0.902.84 (Official build) (64-bit)
Chrome Version 93.0.4577.63 (Official Build) (64-bit)

The problem starts when this is redirected - https:/yoururl.com/index.php/apps/calendar/dayGridMonth/now/edit/popover/L3JlbW90ZS5waHAvZGF2L2NhbGVuZGFycy9zdXBlcmFkbWluL3BlcnNvbmFsLzk4REVFQTdFLUMxQTMtNEJDQS05MjhGLUU1RjQzNjZCMjgyNi5pY3M=/1630454400

For sure others have the same issue. I even tried new installation of NextCloud on a different OS. Result is the same. The funny thing is that I don’t have the same problem on Mobile Chrome.

We need to open a ticket on GitHub, but I don’t know if we need to open an issue for the Calendar App or the Dashboard App. That is why I opened the ticket here.

Do you have a github account, if not i`ll open one for us :+1:t3:

I have one, but have you figured out which one to open a ticket on? Dashboard or Calendar app?

I would say calendar as the dashboard works for everything else.

Alright. This is not the absolute solution, because there is a java loop bug in the calendar app. However, the following workaround solves the issue for each user separately.

Calendar App > From bottom right choose “Settings and Import” > uncheck “Enable Simplified Editor”

Source: https://github.com/nextcloud/calendar/issues/2960#issuecomment-805847876

Thank you so much for you help, this has worked, have you contacted the app developers regarding this?

The developers know about the issue here Canadamcpherson
Upcoming events widget + "create a new event" page does not respond · Issue #2960 · nextcloud/calendar · GitHub but not resolved atm

Since disabling the calendar simplified editor would be an effective workaround to avoid this bug, do you guys by chance know how I could occ apply this setting recursively for all the users of our installation?

I have found some hints on this github issue (sorry for the crosspost but we need to fix this problem as soon as possible!) but I was not able to achieve to batch change that setting for all our users, who lately are complaining a lot about this but.

Any idea? Thank you!