Currently stuck in maintenance mode after upgrade from 19.06 to 20.04

Wondering what is the next step since it remains in Maintenance mode (and seems to be still functioning) at the graphical upgrade process. Does anyone know if it would be safe to reboot the server? or is there a way to diagnose what to do next?
Thanks for any advice.


after some looking around I saw this and tried it;
sudo -u www-data php occ maintenance:mode --off

This was the output;
Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
Maintenance mode disabled

Then I went back to the previous upgrade screen and found it had changed to the one that it shows immediately prior to initiating the upgrade process.
It also show that one of the apps was in need of an update as well, so I restarted the migration to Nextcloud 20.04 and this time it worked as expected.
The situation is salvaged but for how long?
It would be very useful to know what causes this bug and that the system is TRULY capable of deciding when a safe upgrade is possible!


Hello, how did you upgrade ? Though the browser ? If so you have to run sudo -u www-data php occ upgrade and then sudo -u www-data php occ maintenance:mode --off

I did the GUI(browser) upgrade and it has always until now done a good job but this time it stalled at the last step. This is probably just some kind of edge condition which the broswer version has and which the command-line version doesn’t…but every one of these gui failures needs to be prevented by a strong quality assurance ethic, rigorous testing, and better messaging when it occurs.
It is probably not good enough to simply post a message saying …“please check the server logs” and leave the user frozen in place! …as if a gui user would even know how!

come on please!


Mine stops after backing up, and a couple of other way-points in the gui upgrade. I simply push the continue upgrade button (or whatever its called). I’ve never had one fail on me.

Its also better to disable your apps via occ and re-enable them again afterwards I find.