Cron Jobs for Nextcloud on Synology

I’ve just setup a Nextcloud instance on Synology running PHP7.3. Everything seems to be working fine except cron jobs.

Currently, I have the following command running in my Synology Task Scheduler:

curl —insecure https://localhost/nextcloud/cron.php

Unfortunately, the Nextcloud instance gives me “Some jobs haven’t been executed since 16 days ago. Please consider increasing the execution frequency”

Now, I’ve also tried running the following command in my Synology Task Scheduler in an attempt to resolve this:

su -s /bin/sh -c “/usr/local/bin/php73 -f /var/services/web/nextcloud/cron.php” http

This didn’t do much either, instead I received “The last Job Execution ran 12 minutes ago.”

Not really sure how to configure the Task Scheduler here to be able to run the /web/nextcloud/cron.php file from my Synology.

Any help would be greatly appreciated!

Thanks!

Nextcloud version : 19.0.1
Operating system and version : Linux 4.4.59+ aarch64
Apache or nginx version : Apache 7.3
PHP version : 7.3.16

UPDATE 20/0972020

With the intension of trying to solve this, I set it up to run cron.php via Webcron instead, I set this up via cron-jobs.org.

What’s interesting here is that the cron-job is successful, but Nextcloud is still saying “Some cron jobs haven’t been executed in xxx Days” - For reference, I’m attaching a print screen below:

Screenshot 2020-09-20 at 16.59.10

have you checked this post

Hey Vincent,

Thanks for that reply, unfortunately, I’ve already looked through that post. That post is what our current settings is based of, thats why I find it so strange that it’s not working.

Any other suggestions as to why the cronjob for nextcloud isn’t working on Synology would be super helpful!

Thanks!

I use this cron script in Scheduler (by root):
sudo -u http /var/packages/PHP7.3/target/usr/local/bin/php73 -c /usr/syno/etc/packages/WebStation/php_profile/11e7abb1-d10e-43cfb/conf.d/user_settings.ini -f /volume1/web/nextcloud/cron.php

You need to replace paths to php, profile and nextcloud folder

in response to SimyriK’s post on using the Task Scheduler in Synology:

Using your set up the scheduler failed.

I modified it to use the following which works without issue, for me. I use http for the web user.

Run as User: Root

Run Command:
User-defined script:

Put the following in the Script box.
sudo -u http php73 -f /volume1/web/nextcloud/cron.php