Cron Information seems to be hidden

In my Admin Page of Nextcloud the Information about Cron Jobs seems to be hidden?

It is looking like this:

but it was and shoud be like this:

I can’t exactly say when it happen. I am using Nextcloud 12.0.0 at the moment.

Cron Jobs are working well -> syslog under ubuntu server is ok.

It seems as if the site format is not shown correctly or the info is eliminated …

Problem occurs in several browsers (chrome, firefox, edge, )
So it should be serverside problem (php page problem)

Thank you for help
:slight_smile:

You can run the cronjob by hand in order to see if any error pops up and if the status is updated on the admin page:
sudo -u www-data php -f /var/www/nextcloud/cron.php

Yes i did

sudo -u www-data php -f /var/www/nextcloud/cron.php

and no errors occured! Though if I run the cronjob that is defined in crontab.

Although the Info in the Admin Page is not listed - it’s still “hidden”.

It is as if the “variable” isn’t there anymore …??

The date/time on your client and server are correct? There is also a table in your database which lists when the jobs were carried out the last time (oc_jobs).

I’ve checked Systemtime

sudo hwclock --show
-> shows the correct time and date

sudo hwclock --systohc
-> no errors

sudo ntpq -p
-> delivers the list of correct servers that are used
e.g. 0.de.pool.ntp.org

I tried the following today:

hwclock --systohc --debug

That delivers this output: (sorry I didn’t translate it to englisch …)
hwclock von util-linux 2.29
Using the /dev interface to the clock.
Letzte Abweichungskorrektur vorgenommen bei 1502002177 Sekunden nach 1969
Letzte Kalibrierung vorgenommen bei 1502002177 Sekunden nach 1969
Hardwareuhr geht nach UTC Zeit
Die Hardwareuhr läuft vermutlich in UTC.
Auf Uhrtick wird gewartet …
… Uhrtick wurde empfangen
Zeit gelesen aus Hardwareuhr: 2017/08/06 06:55:04
Zeit der Hardwareuhr: 2017/08/06 06:55:04 = 1502002504 Sekunden seit 1969
Time since last adjustment is 327 seconds
Calculated Hardware Clock drift is 0.000000 seconds
1502002504.500000 is close enough to 1502002504.500000 (0.000000 < 0.001000)
Set RTC to 1502002504 (1502002504 + 0; refsystime = 1502002504.000000)
Hardwareuhr wird auf 06:55:04 gestellt = 1502002504 Sekunden seit 1969
»ioctl(RTC_SET_TIME)« war erfolgreich.
Not adjusting drift factor because the --update-drift option was not used.

Hope that this information will help a bit.

In my oc_jobs DataBase the entries are listed as followed
OCA\NextcloudAnnouncements\Cron\Crawler
last run 1501928117
last checked 1502002802

on which entries exactly do I have to look at?

Sat, 05 Aug 2017 10:15:17 GMT

So it didn’t run since then. Was this your manual run?

Entry oc_jobs of today (now)

OCA\NextcloudAnnouncements\Cron\Crawler
last run 1502015406
last checked 1502093701

So this had been changed automatically

And the last post was not the time of a manual initiated run of the cron job.

That also fits to my syslog when every 15 min a log entry is written that shows a run of cron.php in nextcloud without any errors.

But the “problem” still exists that there is no output on the admin page of nextcloud.

I changed it to Ajax update - same - no output of cron in the admin page.
I’m back to cron - because cronjobs are working regarding to the logs and db (oc_jobs) entries…

I can’t figure that out - why the Info is missing on the admin page?

Did you increase the loglevel in php? Other than this, I’m running out of ideas. Then, you could still report a bug on the bug tracker, the developers then can check which function creates a problem. And try the first bugfix release 12.0.1 first, perhaps it was already fixed.

I’ve changed my Log-Level up to DEBUG

Following is logged:

Debug cron Run OCA\User_LDAP\Jobs\UpdateGroups job with ID 236 2017-08-08T07:00:01+0200
Debug cron Finished OC\Authentication\Token\DefaultTokenCleanupJob job with ID 234 in 0 seconds 2017-08-08T07:00:01+0200
Debug cron Invalidating remembered session tokens older than 2017-07-24T05:00:01+00:00 2017-08-08T07:00:01+0200
Debug cron Invalidating session tokens older than 2017-08-07T05:00:01+00:00 2017-08-08T07:00:01+0200
Debug cron Run OC\Authentication\Token\DefaultTokenCleanupJob job with ID 234 2017-08-08T07:00:01+0200
Debug cron Finished OCA\UpdateNotification\ResetTokenBackgroundJob job with ID 221 in 0 seconds 2017-08-08T07:00:01+0200
Debug cron Run OCA\UpdateNotification\ResetTokenBackgroundJob job with ID 221 2017-08-08T07:00:01+0200
Debug cron Finished OC\Log\Rotate job with ID 310 in 0 seconds 2017-08-08T07:00:01+0200
Debug cron Run OC\Log\Rotate job with ID 310 2017-08-08T07:00:01+0200
Debug cron Finished OCA\Passman\BackgroundJob\ExpireCredentials job with ID 281 in 0 seconds 2017-08-08T07:00:01+0200
Debug cron Run OCA\Passman\BackgroundJob\ExpireCredentials job with ID 281 2017-08-08T07:00:01+0200
Debug cron Finished OCA\Files\BackgroundJob\CleanupFileLocks job with ID 7 in 0 seconds 2017-08-08T07:00:01+0200
Debug cron Run OCA\Files\BackgroundJob\CleanupFileLocks job with ID 7 2017-08-08T07:00:01+0200
Debug cron Finished OCA\Files\BackgroundJob\ScanFiles job with ID 5 in 0 seconds 2017-08-08T07:00:01+0200

I’m not sure but it seems to be as it should be?
Cronjob of 7:00 at 8/8/2017 so that fits to my settings crontab => every 15 min

BUT! What about this info

Debug core Scss is disabled for /var/www/nextcloud/core/css/share.scss, ignoring 2017-08-08T07:05:25+0200
Debug core Scss is disabled for /var/www/nextcloud/core/css/server.scss, ignoring 2017-08-08T07:05:25+0200
??

…and I have to mention that I did the Upgrade from 12.0.0 to 12.0.1 yesterday with success.

But my “problem” (admin page without cron Information) resists …

I can’t help you. Please raise an issue on https://github.com/nextcloud/server/issues

From my point of view, the cronjobs seem to run properly but I have no idea why the webinterface doesn’t detect it.