CRON error post upgrade to 21.03

I am a long time Nextcloud user and have never had an issue with the platform. I run background processing with CRON job, and it has worked perfectly for about 5 years.

All of a sudden, I see an error that the cron job has not run for 7 days. I have made no changes except update to 21.03. I have confirmed that the cronjob and that there are no errors in the logs. I have manually run the cron job and it seems to run fine.

I am a bit at a loss of why I am getting this error and how to troubleshoot it. Given my long history with Nextcloud, I am beginning to wonder if this could be a bug.

Anyone have any advice on how to troubleshoot something like this?


Nextcloud version (eg, 20.0.5): 21.03
Operating system and version (eg, Ubuntu 20.04): Ubuntu 18.04
Apache or nginx version (eg, Apache 2.4.25): 2.4.29
PHP version (eg, 7.4): 7.4.21

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): Y, as mentioned

Steps to replicate it:

It appears when I go to the status window

The output of your Nextcloud log in Admin > Logging:

Nothing related to this situation in logging.  The last message was from a week ago.

Mybe this will help you?

1 Like

Thank you. That was it. For future searchers, here is what I did.

Edit: /etc/php/7.4/mods-available/acpu.ini

Made sure that it had the following lines: ← This was already there…


HI, I have the same issue. Does this also apply to my php7.3?

just checked if the file exists on my system → no

I would think that it would, but I bet that it also depends on you having acpu installed and enabled. In your case the file would be located in the following directory: /etc/php/7.3/mods-available.

This is also in Ubuntu and YMMV will vary with other OSes.

unfortunately not

using a synology.

Any other idea why this is not working?

While I use Synology for file sharing, I do not use it for this. However, I believe that it is discussed in this thread and so maybe check that out.