Creating shares not possible, user or usergroups not recognised

Nextcloud version : 19.0.2
Operating system and version: Linux 4.18.0-193.14.2.el8_2.x86_64 x86_64

The issue you are facing:
This is a basic question regarding sharing files and folders. When I want to share a folder or file, I have to enter a name of a user or group. But whatever I try, names of users or user-groups are not recognised. So I can’t make any shares.

Have Googled for similar issues, but could only find topic regarding version 13 which were solved by updating. No updates available now, so need to find another solution.
Can someone please point me in the right direction?

Below you can find some screenshots

Sharing_person_no match

Can someone please take a look at this? Really can’t figure it out myself, any input is highly appreciated

Perhaps you must set this parameter.

Settings -> Administration -> Sharing

If not you must enter the full username because there is no autocompletion.
Test it also if you not really want it.

Thanks for your reply, but that settings was set correct. And still I tried to use the entire usernames, groupnames, emailadresses, nothing worked.

This happened on a server which was built as a copy of another server. Now I deleted it, reinstalled nextcloud and copied the db and now everything works fine

Than it think it was not a nextcloud configuration error (all in db). Funny.