Create Backup fails without indicated reason

When upgrading to 20.0.2, the web updater stopped with the step “Create backup” with no reason given. With older versions it would indicate some files which caused this error. This was not provided here.

From older experience I looked for some files with invalid access rights. I found a copy of my config file with root access right and deleted it. Now the updater runs fine.

I have the same problem

Because I am a beginner, I need more info here.
Where did you find which files? Name and folder

I’m getting the same problem when updating from 20.0.3 to 20.0.4. Nothing in the Nextcloud logging (via the web interface) Nothing in the syslog, dmesg etc. Nothing at all. I’ve checked similar past postings and none apply to my case. :frowning: !
It would be helpful to know where Nextcloud tries to place the backup. Maybe then I could do some further investigation.

I have the same problem.
I’m new to NC. With all 5 updates I have done since I installed NC I had problems.
This is quite annoying. I don’t have access to the command line, so no other choice than using the web updater.

SOLVED :smiley: :sunglasses:
I’ve solved the backup problem on my installation and now I have been able to update.
So, I can recommend doing the following:-

On the command line go to wherever you have the Nextcloud installation and go to the updater directory For me the command is:-
cd /var/www/nextcloud/updater
Then run this:-
sudo -u www-data php updater.phar

That will do the equivalent to the web GUI updater. The difference is that when it comes to try updating you’ll find out what the problem is in regard to the backup. In my case I had previously added some lines of code to the config.php file. This was no problem, however, before I did that I had created a backup file. That backup file was still there and owned by root. The program was unable to backup my config.php.BAK file so it could go no further. So, I simply removed the backup file and all went well.

5 Likes

What if I don’t have access to the command line?

So, how was the installation of Nextcloud done, who administers it for you?

You can install it by uploading the files to your web space through FTP and then run the installation script.
No need to have access to Shell for this.

In my case it was installed through a tool kit, provided by my hoster.

Administration still needs to be done by myself.

When I said ‘administration’ I meant the command line level. OK, I’ve not come across this type of installation before. When you ran this script were you able to see it run? If so, then presumably, you could put the commands I listed below in a script and run that. Alternatively, maybe you could ask your hoster if you can have SSH access.

1 Like

Thank you. This method made me see what was wrong and I corrected it.

Thank you for the insight! Running updater.phar in the shell, revealed that it was a question of /var/www/nextcloud/config/config.bak being not readable due to ownership problems… Hence I was able to fix it!

Thank you! This was very helpful and I was able to figure out what the issue. It was a folder permissions issue. Too bad the GUI doesn’t provide the same information.