Crashes on Login

#1

Hi,

running Nextcloud 3.5.0 (last updated on 13.02.2019) on LineageOS 14.1 (Android 7.1.2) since the same date it first runs just beautiful. Viewing Files, uploading Files, syncing Photos, everything was just fine.
Then I opened the AppClient and had to re-Login (?), tried so but the AppClient just crashes after hitting Login. Tried with User- and Admin account but all the same.

Nothing in the server logs…

I found this Thread which probably addresses the similar topic?

Also this old Thread seems not to be worth to look at

Thanks for any help!

#2

Here is a snippet from the server log (nothing unusal)

172.18.0.1 - user [05/Mar/2019:17:35:59 +0000] "PROPFIND /remote.php/dav/files/user/ HTTP/1.0" 207 1099 "-" "Mozilla/5.0 (Linux) mirall/2.3.3 (Nextcloud)"
172.18.0.1 - user [05/Mar/2019:17:36:01 +0000] "GET /ocs/v2.php/apps/notifications/api/v1/notifications?format=json HTTP/1.0" 200 719 "-" "Mozilla/5.0 (Linux) mirall/2.3.3 (Nextcloud)"
172.18.0.1 - user [05/Mar/2019:17:36:29 +0000] "PROPFIND /remote.php/dav/files/user/ HTTP/1.0" 207 1099 "-" "Mozilla/5.0 (Linux) mirall/2.3.3 (Nextcloud)"
172.18.0.1 - - [05/Mar/2019:17:36:33 +0000] "POST /login/flow/apptoken HTTP/1.0" 303 868 "-" "Sony E6553"
172.18.0.1 - - [05/Mar/2019:17:36:33 +0000] "GET /status.php HTTP/1.0" 200 1052 "-" "Mozilla/5.0 (Android) ownCloud-android/3.4.1"
172.18.0.1 - - [05/Mar/2019:17:36:33 +0000] "HEAD /remote.php/webdav/ HTTP/1.0" 401 1106 "-" "Mozilla/5.0 (Android) ownCloud-android/3.4.1"
172.18.0.1 - user [05/Mar/2019:17:36:34 +0000] "HEAD /remote.php/webdav/ HTTP/1.0" 200 1110 "-" "Mozilla/5.0 (Android) ownCloud-android/3.4.1"
172.18.0.1 - user [05/Mar/2019:17:36:34 +0000] "GET /ocs/v1.php/cloud/user?format=json HTTP/1.0" 200 1771 "-" "Mozilla/5.0 (Android) ownCloud-android/3.4.1"

As you can see, Nextcloud is running in a Docker container on the server.

For some reason whatsoever the AndroidClient is returning itself as ownCloud-adroid/3.4.1 but certainly there is nor was an owncloud on that mobile!