Could not resolve the host nextcloud.com

Hello, I was trying to install Nextcloud on my Raspberry Pi 4 with Raspbian Os Lite. When I run the docker command (present on this page GitHub - nextcloud/all-in-one: Nextcloud AIO stands for Nextcloud All-in-One and provides easy deployment and maintenance with most features included in this one Nextcloud instance.) it gives me an error saying ‘Could not resolve the host nextcloud.com’ and also, the container goes into bootloop. How can I fix? Thanks!

Hi, there should be some ideas shown what to do in that case.

Yes, in the error message there were links that gave you information to try to solve, I tried but it didn’t work

What did you try, what didn‘t work?
What happened?
Sorry, but I lost my crystal ball… :kissing_heart:

i tried this How to fix sudden dns resolution issues after the AIO update to v4.4.1 or higher. · nextcloud/all-in-one · Discussion #2065 · GitHub but the container of nextcloud aio kept going into bootloop

There must be a different proposed solution. Did you try that as well?

yes, i tried it

What version of Raspbian OS Lite? Do you have any other containers running in your Docker environment?

Let’s check the basics:

  • Can you ping nextcloud.com successfully from the Raspberry Pi 4?

If “yes” then let’s check connectivity from within your Docker environment:

  • Does doing a ping form inside a simple container work: docker run -it --rm alpine:latest ping nextcloud.com?

If not, you have something wrong with your Docker installation.

1 Like

The OS version is Debian 11, the Raspberry can ping the nextcloud.com but docker can’t, it says ping: bad address ‘nextcloud.com

P.S. While I’m at it I would like to ask another question: from Nextcloud AIO can I change the destination folder of the files? And as destination folder can I use a disk with already files without formatting it?

I found this for you.

You must not format the folder. But files in the folder is a bad idea. If you want re-import files i would install Nextcloud normal in empty folder, put the files in the user data-directory and then re-scan the files read this. For Docker you must modify the command.

Update: i tried to create an ubuntu container for do some tests and that container can ping nextcloud.com, so i have no idea why the Nextcloud AIO container can’t

Maybe because the aio container uses alpine as base which you verified is not able to ping nextcloud.com? Anyway, this is something that needs to be fixed in your infrastucture.

Yes, you’re right, and I think I’ve found the problem. I tried to create the Nextcloud AIO container on my laptop using my phone’s 4G connection and it worked, so it’s a problem with my DNS server (pi-hole) which I will now try to fix.

2 Likes