Copy/pasted E2EE Passphrase isn't accepted

Nextcloud version (eg, 12.0.2): 18.0.0.10
Operating system and version (eg, Ubuntu 17.04): Ubuntu 18.04
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4
PHP version (eg, 7.1): 7.3

The issue you are facing:
E2EE-Passphrase isn’t accepted after creation. Clients stop syncing.

Steps to replicate it:

Not sure if it’s reproducible, so here’s just what I did:

  1. Turned on E2EE using Nextcloud Desktop 2.6.2stable-Win64
  2. Copy/pasted the created passphrase into password manager
  3. Client refused to sync (Taskbar icon gray), restarted Client
  4. Asked for E2EE Passphrase
  5. Pasted from password manager, hit OK
  6. GOTO 4, no error message nor log entry

Essentially I have to cancel the passphrase prompt, after which the client won’t do any sync operations, even on folders that are not encrypted.

The output of your Nextcloud log in Admin > Logging:

[no app in context] Error: Exception: Too few arguments to function OCA\FilesAccessControl\StorageWrapper::file_put_contents(), 1 passed in /var/www/nextcloud/lib/private/Files/View.php on line 1162 and exactly 2 expected at <<closure>>

0. /var/www/nextcloud/lib/private/AppFramework/App.php line 125
   OC\AppFramework\Http\Dispatcher->dispatch(OCA\EndToEndEncr ... {}, "setPrivateKey")
1. /var/www/nextcloud/lib/private/AppFramework/Routing/RouteActionHandler.php line 47
   OC\AppFramework\App::main("OCA\\EndToEndEn ... r", "setPrivateKey", OC\AppFramework\ ... {}, {_route: "ocs.en ... "})
2. <<closure>>
   OC\AppFramework\Routing\RouteActionHandler->__invoke({_route: "ocs.en ... "})
3. /var/www/nextcloud/lib/private/Route/Router.php line 299
   call_user_func(OC\AppFramework\ ... {}, {_route: "ocs.en ... "})
4. /var/www/nextcloud/ocs/v1.php line 82
   OC\Route\Router->match("/ocsapp/apps/en ... y")
5. /var/www/nextcloud/ocs/v2.php line 24
   require_once("/var/www/nextcloud/ocs/v1.php")

POST /ocs/v2.php/apps/end_to_end_encryption/api/v1/private-key?format=json
from 192.168.2.50 by user at 2020-02-04T18:05:58+00:00

The output of your Apache/nginx/system log in /var/log/____:

error.log:
[Tue Feb 04 19:05:53.519195 2020] [access_compat:error] [pid 4139:tid 140610146150144] [client 192.168.2.50:56028] AH01797: client denied by server configuration: /var/www/nextcloud/config
[Tue Feb 04 19:08:37.510846 2020] [access_compat:error] [pid 4139:tid 140610146150144] [client 192.168.2.50:56144] AH01797: client denied by server configuration: /var/www/nextcloud/config
[Tue Feb 04 19:32:57.053394 2020] [access_compat:error] [pid 4139:tid 140610112546560] [client 192.168.2.52:49729] AH01797: client denied by server configuration: /var/www/nextcloud/config

I should add that no files are encrypted as of yet. I only want E2EE working from this point forward.
So loosing the current, probably broken key set isn’t an issue at all.

Creating a new account, as suggested here, on the other hand is not feasible

E2EE isn’t working. Only use it with test setup.
Like the app description says: “End-to-end encryption is still in alpha state, don’t use this in production and only with test data!”
Hopefully you have noticed this already.

So, don’t wait fast solution. Good luck! Hopefully we get working e2ee someday.

Actually it was put as stable in the store so I didn’t have those warning.
And so I enable it but the clients are not accepting the passphrase and I don’t find a way to delete and/or reset the module so that the clients do not ask for the passphrase anymore …
so is there somewhere some help.

https://apps.nextcloud.com/apps/end_to_end_encryption
Description still says alpha state…

Okey thanks for pointing that out to me because usually you have in the store something like « enable untested app »

1 Like