Contacts not all imported from vcard file *.vcf

I am running Contacts 5.0.2 on Nextcloud Hub 3 (25.0.2)
I tried to load 53 additional contacts in a particular group from the Contacts interface. I did this individually (of course). However, although all appeared to go well, some contacts did not ‘persist’ on refresh. Some contacts were incomplete e.g. Only the first letter of the FN appeared. It seemed the database was corrupt so I downloaded the vcf file and edited it manually in a text editor (Notepad ++). For the new contacts I left the UID blank (as on the Forum someone said this information is supplied automatically. I then deleted the contacts file (under ‘settings’), created a new file and uploaded the edited vcf to Contacts. All contacts appear OK (no sanity issues like before) but there are only 30 files in the particular ‘group’ but the Contacts interface reports that there are 53. There are 53 separate entries in the uploaded vdf file. Perhaps highlighted advice is wrong? Having said that, one vcard where the UID was left blank comes up nicely.

This issue seems solved. It seems a vcard will not be imported into Contacts app unless it has a UID. These can be generated at https://www.uuidgenerator.net/
I don’t know why one file was imported without a UID.
Others with more knowledge than me may be able to provide a better explanation.
One other problem was that, on importing all vcards, there was one duplicate. I tried deleting it but received an error message that it could not be deleted. However, on refreshing the page, it was deleted.