Contacts app only shows spinning wheel but no content in webview

Hello,
I just updated from ownCloud 9.0.2 to Nextcloud 9.0.53 and activated Calendar and Contacts app.
When choosing Contacts, only a “spinning wheel” is displayed, no actual content.
The log does not show relevant entries - where could I have another look?
Thanks!

Hi @abockhold,

I’m sorry to hear about your upgrade experience. I have a few questions, which may help us to assist you.

  • Does this only happen on a single account or on the whole instance?
  • Are you able to load your contacts with a CardDAV Client? (like OS X Contacts or DAVdroid)
  • Can you provide us more details about your instance? (OS, Webserver, PHP version, …)

Hi mar1u5,
as this is a testing instance, there has been just one user (the administrator) with which I have the problem. For testing purposes I now created another user without admin rights - this user does show correctly “no contacts” (or whatever it says in english).
There have not been any contacts beforehand - I tried to create one via CardDAV for my administrator now. That worked fine, I did not receive an error.
The box is Debian GNU/Linux 8 “Jessie” with Apache 2.4.10-10+deb8u5 and PHP 5.6.24+dfsg-0+deb8u1.

So it is not an error with the server or especially with the dav-backend, because you are able to use the CardDAV backend with clients :wink: …it seems to be a bug in the frontend (the “contacts”-app).

Could you open an issue on GitHub … You just need to fill out the issue template :muscle: Please mention me by writing “@mar1u5” at the end of your issue. If you dont have an account there, and you dont want to create one - just ask me, and i will report the issue for you after some more questions from the issue template :wink:

If you need more help with that, feel free to ask here, or ping me on IRC :speech_balloon:

This bug has been reported on Github since 3 June 2016…
see here : https://github.com/owncloud/contacts/issues/430#
(many comments, many affected users but still no one assigned)

Thank you for your comment on that @Akhenaton :punch:

Also seen that … The reason why I have not said it is exactly the same bug is, that it is only appearing to him after the upgrade of the server - not of the contacts-app :wink: …but yes. You are right. It seems to be the same issue in some way.

Interessting that no one has commented on that, since it seems to be a “bigger” problem, which makes it impossible to use it if you have invaild vcards :grin:

There were some testing vcards tested by @jospoortvliet which break up the contacts app:
https://github.com/owncloud/contacts/issues/446

We should discuss this again. Thank you for letting me know that - I will take care of that some of our devs are looking on that :muscle:

I’ll keep you updated :see_no_evil:

Thanks for all the information! I try to add my observations:

Well, I updated the server, yes. After that I activated the contacts app - probably it has not been activated anytime before. I think it’s a “clean first install” for the app alone.

Therefore it is strange for another reason: there shouldn’t be any contact (which could be corrupted) for the admin user?! Where should it come from?

For me there is no error message in the contacts app, only a spinning wheel.

In the admin panel, too, there is no message regarding contacts or anything else (set to “all errors”).

Any idea, whether this is issue #430 or something else?

BTW: great responses here, thanks!

An addition, from the before mentioned Github issue:

Using a login with a space in the name (“Test 1”) triggers the problem, accounts without space (“Test1”) work fine…

@mar1u5 Could you mentione this at Github? Currently I don’t have an account there. Thanks!

I have seen the same issue when adding a contact that was broken, see the closed issue here: https://github.com/owncloud/contacts/issues/446

There is a lot of vcards in the repo I link to which break the Contacts app instantaneously.

Hi again,
just for my understanding: the contacts app is jointly developed by Nextcloud and Owncloud? Therefore it would be advisable for me to push this matter at Github and not in this channel?
As this is a show stopper for me because the vast majority of my accounts have a space in them…
Thanks all!

On my server under nC 10.0.0, the issue exists only for users with a blank in the username…
Max Mustermann
doesn’t see his adresses, just the spinning wheel…

Max_Mustermann
works as expected…

Both users have the same adresses

I cannot confirm that this happens for users with a blank in the username only.

We have a user with a single username but his contacts are not displayed but just the "spinning wheel“. Other users do not have this problem though. This happens all the way up from Nextcloud 9 and now up to Nextcloud 10.

We tried different versions of the Contact App compatible with ownCloud/Nextcloud 9.x including some sources from GitHub. We did run the user’s contacts through some VCF fixing tools and re-imported them but still the same happens on the web interface: Nothing more than the spinning wheel.

Strangely, the user’s contact list shows fine on Roundcube with a CardDav Plugin, iOS devices and Thunderbird with SoGo Connector.

Im afraid, there are 2 different errors in the app with are handled together.

  1. If there are broken cards, the spinning wheel ist shown
  2. If the user has a blank in his name the spinnening wheel is show.

In both cases caldav syncing with android and thunderbird works.
No 2 is reproducable on my system under NC 9.1.0.16 and Ubuntu 16.04 on odroid xu4:
just create two Users, 1. Max Mustermann with and 2nd Max_Mustermann without blank in Name.
The 1. only gets the spinning wheel.
Syncing the same adresscards to both users works and after that nothing changes: User 1 sees the spinning wheel, user 2 works as expected…

Perhaps sombody could try this on his system und the issue in github should split into two issues?

it is ‘community developed’ at the moment, though we spend a bit of time on it and that’ll get more in the future. The maintainer will have to decide to move it to another repo perhaps, at some point. For now, calling it ‘jointly developed’ is probably reasonably correct.

I had exactly the same issue some time ago. The fix is to select a color for the calender. During the upgrade from one version to another the color field has been added. However it is empty and javascript doesn’t find it so it is looking for it forever …

Can’t explain the issue with the two newly unter NC 9.1.0.16 aka 10.0 created Users Max Mustermann and Max_Mustermann

Fix loading spinner with usernames containing spaces:


:slight_smile:

Hi - My username is 1 word with no spaces, and I encountering the spinning wheel issue as well on a shared hosting account. There is a lot of discussion around this, but is there a definitive issue or issues with this that has been discovered?

mp/m

Hi - as a follow-up… I got my contacts working.

Reading thru all of the information on this issue, I decided to go thru them all, starting with the possibility of corrupt contacts, so I backed them up to an Excel file and started deleting them. About 5 in, they started loading!

So what could have been the issue? I know one contact had 6 phone numbers in it. A couple had photos. So after celebrating and adding them back in, I also added photos to a couple, and I saw the load time increase, which may be a contributing factor. Of course I will troubleshoot this with low-res photos, etc.

mp/m

I just marked a bugfix for usernames with containing spaces as solution which was the report of the OP (it should be in version 1.4 of the contact-app). If there are other problems that show spinning wheels, please open a new topic.