Contacts App 3.1.4 - Internal Server error

Hello,

since I’ve updated the contacts app to the newest version 3.1.4 I get an error:

Internal server error
The server could not complete the request.
If this happens again, please send the following technical details to your server administrator.
Further details can be found in the server log.
Technical Details
Remote address: 10.0.0.138
Request identifier: XZBbCqn26LKl8uEPVuwECgAAQAs

But the error message only appears by opening the contacts app. All of the other apps work without problems.

Any ideas to solve the issue?

Kind regards,
Michael

Hey Michael.
There is indeed a bug in the last version. This is not compatible with nextcloud 15. Please either downgrade to 3.1.3 or upgrade nextcloud to 16/17, or wait for the next fix incoming next week!

Envoyé depuis ProtonMail mobile

-------- Message d’origine --------
On 29 sept. 2019 à 09:39, Michael via Nextcloud community < noreply@nextcloud.com > a écrit :

Thanks for the fast response. Then was my assumption right.
By the way: Is there generally a option (app history) to downgrade apps. Or is this only with a backup possible?

Yes, you can uninstall the contact app, download an old version from the app store, and extract the contacts.tar.gz in your apps folder. Then enable it on your instance :slight_smile:

Envoyé depuis ProtonMail mobile

-------- Message d’origine --------
On 29 sept. 2019 à 12:37, Michael via Nextcloud community < noreply@nextcloud.com > a écrit :

1 Like

Ok, I downloaded an older version. But how can I copy the file from Windows to the Raspi and extract it in the app folder? Where is the app folder?

1.) You can use e.g. WinSCP to copy the files to the Raspberry Pi.
2.) You can use tar or the Midnight Commander (mc), if it is installed on your server.
3.) The apps folder is a sub directory of the Nextcloud root directory.

1 Like

Thank you very much. The downgrade was successful. Although it was a bit tricky. To got access to the nextcloud folder I had to change “PermitRootLogin=Yes” in “sshd_config”. After I’ve changed the folder of contacts app, the apps works now without problems.
After the procedure I changed “PermitRootLogin=No”.

Thank you very much for your help!

Mind to reset that parameter again to keep your server secure. Usually you should login as user “pi”, copy files to the server and then move them to the destination directory. :wink:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.