Contacts and calendar with DAVdroid and 1.3.0 app

I have tried this integration however after asking me for my password it just says "Couldn’t find CalDAV or CardDAV service. The first time I tried, it installed DAVdroid but there after I receive the error. I’m wondering if the auto filled in URL line is correct. Has anyone else got this working?

Hi,

I just tried it and it worked fine. The URL and username given to DAVdroid are the same that Nextcloud uses. I had to manually type the password into DAVdroid, but I think that’s expected.

Edit: Sorry, forget to list the software.

Nextcloud 10
DAVdroid 1.3-ose
Nextcloud client 1.3.0

I have Nextcould 10 as well. If I look at the URL that contacts has when you share it is:
https://server/nextcloud/remote.php/dav/… etc but the url the android client offers is just
http://server/nextcloud/, I assume that is supposed to work and something else is not correct?

Hi,

In my case the Android client url was just https://sub.domain.ext. There was no remote.php/dav or any sub path. This should work assuming you have the proper redirects in. Have you set up the .well-known urls?

What happens when you visit yourdomain.ext/.well-known/caldav or yourdomain.ext/.well-known/carddav?

Well I have this configured so when I access the calendar with my browser for example, the url works out to be: https://server/nextcloud/apps/calendar/

So I believe the well known URL’s or “pretty URL’s” as they call them in the installation manual are enabled.
It works (but is flakey if one tries the manual sync) if I add remote.php/dav/ after the url so
https://server/nextcloud/remote.php/dav/.

I also had to run davdroid and click the check marks beside each item under my account. It certainly doesn’t seem like a one step configure.

It is a step in the right direction though, thanks to the folks that worked on this. I think it just needs a bit of fine tuning.

@grouchysysadmin exactly, we don’t send the password since this could (theoretically) be intercepted

@George_Farris yes, DAVdroid wants us to send the plain, main URL and DAVdroid uses its internal detection implementation to find the fitting deep address. If this isn’t working as a one-click+password it is either an issue in DAVdroids detection logic (which they would fix I think) or if they say it works in their opinion a server-side issue. So first thing I would recommend is that you just ping the DAVdroid guys, maybe by reporting an issue.

All in all, thank you for your patience and appreciating! :slight_smile:

Works like a charme here …

Nexus 9 with Android Nougat // Nextcloud 1.3.1 // Davdroid 1.3.1

Cheers,
Andreas

1 Like

@George_Farris I was having the same issue. I eventually found out that I didn’t have “.well-known” redirects setup in my root .htaccess (file wasn’t there, I had to create it).

Redirect 301 /.well-known/carddav /nextcloud/remote.php/dav
Redirect 301 /.well-known/caldav /nextcloud/remote.php/dav

https://docs.nextcloud.com/server/10/admin_manual/issues/general_troubleshooting.html#troubleshooting-contacts-calendar

Hello there!

The thread is a bit old but I just faced similar issues and this thread has not been very helpful in my case, but it is one of the easiest to find a pretty much all the custom help available.
Took me some to find my answer so I am sharing it :

After installing 'Two-Factor TOTP Provider ’ and set up TOTP on my account, i faced the message :
“Couldn’t find CalDAV or CardDAV service”
If you are having the same, you have to go to the the security pannel of nextcloud and set a password for a spefic app, to do so :

Setting > security > all the way down : Create new app password

then log to DAV5x with this password!

Sorry if bringing back this thread was not a good thing to do but I feel this might help some …

1 Like