Contacts and Calendar do not work

I am migrating from onwCloud. I have got the latest ownCloud running on a Debian Stable server. I installed nextCloud, ran the upgrade script, pointed lighttpd to the new nextCloud directory, logged in - so far, so good.
I activated calendar and contacts apps, but when accessing calendar, it does not show my calendars or events. Contacts only shows a blank white page.

There were updates for the calendar app, but I was not able to install them - no error msg, though.

When I point my webserver to ownCloud again, that installation works totally fine. Server log files did not show anything that helped me find the problem.

Can anyone pls help here?

Of which versions of OC and NC are your talking, 9.1.0 and 10.0?

Yes, 9.1.0 and 10.0.

Can you check the browser error console?
Did you make a copy of your initial owncloud setup or why can you easily switch back?

I installed NC in a new directory, and only copied the config file and data folder. Will check browser error console tonight when I am back home.

When accessing the NC home page, this is the error console output:


Content Security Policy: Directive ‘frame-src’ has been deprecated. Please use directive ‘child-src’ instead.(unknown)
Content Security Policy: The page’s settings blocked the loading of a resource at self (“script-src my.server ‘unsafe-eval’”).files:1
GET
my.server/apps/files_sharing/js/external.js [HTTP/1.1 404 Not Found 72ms]
GET
my.server/apps/contacts/img/app.svg [HTTP/1.1 404 Not Found 72ms]
GET
my.server/apps/calendar/img/calendar.svg [HTTP/1.1 404 Not Found 72ms]
JQMIGRATE: Migrate is installed, version 1.4.0jquery-migrate.min.js:2:542
window.controllers is deprecated. Do not use it for UA detection.ace.js:1716
GET
my.server/apps/contacts/img/app.svg [HTTP/1.1 404 Not Found 72ms]
GET
my.server/apps/calendar/img/calendar.svg [HTTP/1.1 404 Not Found 72ms]
TypeError: OCA.Files.SidebarPreviewManager is not a constructor
mainfileinfodetailview.js:89:27
TypeError: this.fileList is null
app.js:130:5


Calendar yields these errors:


GET
my.server/apps/calendar/js/vendor/fullcalendar/dist/fullcalendar.css [HTTP/1.1 404 Not Found 73ms]
GET
my.server/apps/calendar/js/vendor/jquery-timepicker/jquery.ui.timepicker.css [HTTP/1.1 404 Not Found 142ms]
GET
my.server/apps/calendar/css/globals.css [HTTP/1.1 404 Not Found 193ms]
GET
my.server/apps/calendar/css/calendar.css [HTTP/1.1 404 Not Found 192ms]
GET
my.server/apps/calendar/css/calendarlist.css [HTTP/1.1 404 Not Found 193ms]
GET
my.server/apps/calendar/css/datepicker.css [HTTP/1.1 404 Not Found 143ms]
GET
my.server/apps/calendar/css/eventdialog.css [HTTP/1.1 404 Not Found 167ms]
GET
my.server/apps/calendar/css/settings.css [HTTP/1.1 404 Not Found 178ms]
GET
my.server/apps/calendar/js/vendor/jquery-timepicker/jquery.ui.timepicker.js [HTTP/1.1 404 Not Found 72ms]
GET
my.server/apps/calendar/js/vendor/ical.js/build/ical.js [HTTP/1.1 404 Not Found 72ms]
GET
my.server/apps/calendar/js/vendor/jstzdetect/jstz.min.js [HTTP/1.1 404 Not Found 73ms]
GET
my.server/apps/calendar/js/vendor/angular/angular.js [HTTP/1.1 404 Not Found 72ms]
GET
my.server/apps/calendar/js/vendor/angular-route/angular-route.js [HTTP/1.1 404 Not Found 72ms]
GET
my.server/apps/calendar/js/vendor/angular-bootstrap/ui-bootstrap.min.js [HTTP/1.1 404 Not Found 72ms]
GET
my.server/apps/calendar/js/vendor/angular-bootstrap/ui-bootstrap-tpls.min.js [HTTP/1.1 404 Not Found 73ms]
GET
my.server/apps/calendar/js/vendor/angular-ui-calendar/src/calendar.js [HTTP/1.1 404 Not Found 72ms]
GET
my.server/apps/calendar/js/vendor/fullcalendar/dist/fullcalendar.js [HTTP/1.1 404 Not Found 72ms]
GET
my.server/apps/calendar/js/vendor/fullcalendar/dist/lang-all.js [HTTP/1.1 404 Not Found 73ms]
GET
my.server/apps/calendar/js/vendor/davclient.js/lib/client.js [HTTP/1.1 404 Not Found 73ms]
GET
my.server/apps/calendar/js/public/app.js [HTTP/1.1 404 Not Found 73ms]
GET
my.server/apps/contacts/img/app.svg [HTTP/1.1 404 Not Found 125ms]
GET
my.server/apps/calendar/img/calendar.svg [HTTP/1.1 404 Not Found 109ms]
JQMIGRATE: Migrate is installed, version 1.4.0jquery-migrate.min.js:2:542
Content Security Policy: The page’s settings blocked the loading of a resource at self (“script-src my.server ‘unsafe-eval’”).calendar:1
GET
my.server/apps/calendar/img/favicon.ico [HTTP/1.1 404 Not Found 75ms]
GET
my.server/apps/calendar/js/vendor/jquery-timepicker/jquery.ui.timepicker.js [HTTP/1.1 404 Not Found 77ms]
GET
my.server/apps/calendar/js/vendor/ical.js/build/ical.js [HTTP/1.1 404 Not Found 74ms]
GET
my.server/apps/contacts/img/app.svg [HTTP/1.1 404 Not Found 73ms]
GET
my.server/apps/calendar/img/favicon.ico [HTTP/1.1 404 Not Found 0ms]


Contacts:


GET
my.server/apps/contacts/css/public/style.css [HTTP/1.1 404 Not Found 73ms]
GET
my.server/apps/contacts/js/vendor/angular/angular.js [HTTP/1.1 404 Not Found 73ms]
GET
my.server/apps/contacts/js/vendor/angular-route/angular-route.js [HTTP/1.1 404 Not Found 74ms]
GET
my.server/apps/contacts/js/vendor/angular-uuid4/angular-uuid4.js [HTTP/1.1 404 Not Found 166ms]
GET
my.server/apps/contacts/js/vendor/angular-cache/dist/angular-cache.js [HTTP/1.1 404 Not Found 153ms]
GET
my.server/apps/contacts/js/vendor/angular-sanitize/angular-sanitize.js [HTTP/1.1 404 Not Found 176ms]
GET
my.server/apps/contacts/js/vendor/ui-select/dist/select.js [HTTP/1.1 404 Not Found 182ms]
GET
my.server/apps/contacts/js/dav/dav.js [HTTP/1.1 404 Not Found 114ms]
GET
my.server/apps/contacts/js/vendor/vcard/src/vcard.js [HTTP/1.1 404 Not Found 173ms]
GET
my.server/apps/contacts/js/public/script.js [HTTP/1.1 404 Not Found 80ms]
GET
my.server/apps/contacts/js/vendor/angular-bootstrap/ui-bootstrap.min.js [HTTP/1.1 404 Not Found 125ms]
GET
my.server/apps/contacts/js/vendor/angular-bootstrap/ui-bootstrap-tpls.min.js [HTTP/1.1 404 Not Found 115ms]
GET
my.server/apps/contacts/js/vendor/jquery-timepicker/jquery.ui.timepicker.js [HTTP/1.1 404 Not Found 103ms]
GET
my.server/apps/contacts/img/app.svg [HTTP/1.1 404 Not Found 154ms]
GET
my.server/apps/calendar/img/calendar.svg [HTTP/1.1 404 Not Found 138ms]
JQMIGRATE: Migrate is installed, version 1.4.0jquery-migrate.min.js:2:542
Content Security Policy: The page’s settings blocked the loading of a resource at self (“script-src my.server ‘unsafe-eval’”).contacts:1
GET
my.server/apps/contacts/img/favicon.ico [HTTP/1.1 404 Not Found 72ms]
GET
my.server/apps/contacts/img/app.svg [HTTP/1.1 404 Not Found 73ms]
GET
my.server/apps/contacts/img/favicon.ico [HTTP/1.1 404 Not Found 0ms]


Seems like for some reason NC cannot access the apps. Ideas?

Got it. The config file still pointed to the OC app directory. Changed that, and all seems to work fine now. Thanks for helping!