Connection Wizard is looping between "Log in" and "Grant access"

I have a working installation of Nextcloud 15 (in a docker container, behind a nginx reverse proxy over https), and the iOS app has no pb connecting to it, as well as the web interface.

When running the connection wizard from the Windows 10 Installer, I enter my login/password and the wizard then asks to grant access to Mozilla/5.0. I grant the access, but from there, it loops back to the login page “Connect to your account”, and then again to grant access, and so on for ever.

I have no idea what is going on. Could it be related to the fact that my nextcloud container listens to port 80, and “sees” https only through the reverse proxy?

NB: the alternative “log in using app token”, once provided with a valid token obtained from the settings of the web interface, fails an returns a 405 error.

Thanks a lot for your help!

1 Like

That could be the reverse proxy. I had the same problem. The solution for me was to add the ‘overwriteprotocol’ variable to config.php and set it to “https”. See: server/config/config.sample.php at master · nextcloud/server · GitHub

Unfortunately, I ran directly into the next problem with it:


Dear xotox91,
Thanks a lot for the overwriteprotocol idea, it solved my problem!

I had the same issue and this fixed it for me too. Thanks.

Me too, thank you! <3
I wasn’t going through a revproxy–at least not on the intranet–but it still worked. Thanks! :smiley:

The overwriteprotocol solution helped me as well, thank you!
This can vary for others, but for reference here’s what I had to do to stick this change into my docker container:

docker exec -it nextcloud /bin/bash
apt-get update
apt-get install -y vim
cd config/
vim config.php
insert the line: 'overwriteprotocol' => 'https',

I used the overwriteprotocol solution and it worked. Thank you!