Connecting nextcloud-app takes forever to connect

My nextcloud android app is unable to register in my nextcloud-server.

I register via username/password (already tested all other options too) and it seems that no response comes from my nextcloud-server.
Before pressing the connect button, a hint appears: “Strict mode: no http connections allowed”.

I’m using nextcloud 25.0.12 and nginx as reverse-proxy (basically this settings).

Using nextcloud via web-interface, or setting up my nextcloud in davx5 (to sync tasks, etc) works well!
FYI: My davx5 setup only worked with manually entered url/username/password! Setting it up via login flow via browser (wich is what nextcloud-app does) did not work, too.

Before I used nginx, I connected to my nextcloud-server directly and everything worked fine.

Please post your actual configuration (occ config:list system and your nginx config).

Also, even though things seem to be working from your browser, please try to logout and login via your browser with your Network tab open and see if anything indicates a failure.

My best guess with the limited information provided is that you don’t have the appropriate overwrite* parameters in-place (or the ones you have aren’t completely correct).

If you search the forum you’ll see that error message. Also the Admin Manual documents the overwrite* parameters.

wow! nice guess! :smiley:

i specified the wrong overwriteprotocol and overwrite.cli.url parameters.
i changed that to https and now everithing works fine :slight_smile:

Thanks a lot :v: