Confused trying to mount NAS

I have nextcloud AIO running and accessible but I can’t seem to get it to mount my NAS drive for access to my digikam photos and files.

I have tried a number of things and yes the external storage app.

  - 'nextcloud_aio_mastercontainer:/mnt/docker-aio-config'
  - '/var/run/docker.sock:/var/run/docker.sock:ro'
  - '/mnt/sdb/mymedia:/var/www/html/photos:rw'
  - '8080:8080'
  - APACHE_PORT=11000
  - NEXTCLOUD_MOUNT=/mnt/sdb/mymedia

This above didn’t work.
There is no local option in the external app
When i tried to use smb and mount as a share using the app all I get is a red configuration error.
(Yes I can mount the share outside of nextcloud)
I am thinking I need to add something else to the compose file but no idea.

This looks good to me in general.

Did you already restarted the containers from the AIO interface and applied the outlined permissions?

See GitHub - nextcloud/all-in-one: Nextcloud AIO stands for Nextcloud All-in-One and provides easy deployment and maintenance with most features included in this one Nextcloud instance.

With that mount I still need the extension app?
Do I need it in volumes as well?

As far as I know it’s permissioned correctly.

Should I try to look
At nextcloud.log ?

I don’t see
Anything appear in the files or photo section when in nextcloud

No, not needed

Have you read the doc that I’ve sent to the end?

@szaimen there is no local option in my external app.

Fid you already resrart the containers from the AIO interface?

@szaimen I am staring fresh install now and will keep you posted. How do I force inactive user timeout?

If you want to access your nas from within nextcloud you should not mount it this way, there is an app for that in the nextcloud appstore “external storage” there you can mount smb or nfs shares and nextcloud will give you access

@dcazman1 a fresh install is not needed. Did you actually restart the containers from the AIO interface after adding the variable NEXTCLOUD_MOUNT to the mastercontainer?

@szaimen local appeared in the external app after fresh install. I am new to nextcloud so reinstall was not a big deal.
How do I set a inactive user timeout / logout ?

Please open a new thread for this. Thanks!